If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Setup cron job to update locale directory on bedrock prod

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: Other
P1
blocker
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: jlongster, Assigned: solarce)

Tracking

Details

(Reporter)

Description

6 years ago
During the last push, solarce set up the "locale" directory on bedrock prod to pull from an SVN repo. It needs a cron job to update it every 15 minutes.

It doesn't seem to be working, so can someone check it and make sure it's running a cron job and it's pulling from the production branch in SVN?

This is a blocker because localizers need to sign off on some localizations for tomorrow's Firefox release.
(Reporter)

Updated

6 years ago
Blocks: 747635
(Assignee)

Comment 1

6 years ago
Investigating
Assignee: server-ops → bburton
Status: NEW → ASSIGNED
(Reporter)

Comment 2

6 years ago
It's possible that there's an issue with caching within the django site, but I'd like to make sure this is working first. Thanks!
(Assignee)

Comment 3

6 years ago
This should be working now, I hadn't committed the cron job to puppet :/

I added a step that outputs to http://www.mozilla.org/media/locale_finished.txt, so you can check there to see the last time of the run

It should run at 9:30 and I'm watching the cron log to make sure
(Reporter)

Comment 4

6 years ago
(In reply to Brandon Burton [:solarce] from comment #3)
> This should be working now, I hadn't committed the cron job to puppet :/
> 
> I added a step that outputs to
> http://www.mozilla.org/media/locale_finished.txt, so you can check there to
> see the last time of the run
> 
> It should run at 9:30 and I'm watching the cron log to make sure

That's awesome! Thanks! Works great.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

6 years ago
Confirmed run 'finished at Mon Apr 23 09:45:04 PDT 2012' at via http://www.mozilla.org/media/locale_finished.txt
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
Looks like we're now getting emails every 15 min with this text. Any way to avoid that?

[2012-04-23 10:00:05] Running rsync_project
[2012-04-23 10:00:05] [localhost] running: ...
[2012-04-23 10:00:09] [localhost] finished: ...
[2012-04-23 10:00:09] Running push_www
[2012-04-23 10:00:09] [bedrock1.webapp.scl3.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock2.webapp.scl3.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock3.webapp.scl3.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock4.webapp.scl3.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock5.webapp.scl3.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock1.webapp.phx1.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock2.webapp.phx1.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:09] [bedrock3.webapp.phx1.mozilla.com] running: /data/bin/update-www.sh www.mozilla.org-django
[2012-04-23 10:00:10] [bedrock3.webapp.phx1.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (1.557s)
[2012-04-23 10:00:10] [bedrock2.webapp.phx1.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (1.695s)
[2012-04-23 10:00:11] [bedrock4.webapp.scl3.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (2.028s)
[2012-04-23 10:00:11] [bedrock5.webapp.scl3.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (2.028s)
[2012-04-23 10:00:11] [bedrock1.webapp.phx1.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (2.219s)
[2012-04-23 10:00:12] [bedrock1.webapp.scl3.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (3.601s)
[2012-04-23 10:00:12] [bedrock3.webapp.scl3.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (3.625s)
[2012-04-23 10:00:12] [bedrock2.webapp.scl3.mozilla.com] finished: /data/bin/update-www.sh www.mozilla.org-django (3.651s)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

6 years ago
Should be fixed with the next cron run, I've added myself to the cron email to confirm
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

6 years ago
Seems to be good now

Apr 23 10:15:01 bedrockadm CROND[18296]: (root) CMD (/data/bedrock/src/update-www.mozilla.org-cron-svn-locale.sh &> /dev/null)
Status: RESOLVED → VERIFIED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.