Closed Bug 747957 Opened 10 years ago Closed 10 years ago

No scroll-bar in pre elements with one line and style="overflow: auto; padding: 0;"

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 726258

People

(Reporter: spammed.user, Unassigned)

References

()

Details

<pre> elements with one line and style="overflow[-x|-y]: auto; padding: 0;" are rendered without scroll-bars, even if they should. Setting the padding to a different value fixes the problem, even if it's then reset to 0 with JS.

Enter the web page above ( http://jsfiddle.net/yeDyT/7/ ) for an interactive demonstration. Focus on the 'Result' panel.
This works fine for me in a current nightly on Mac, on that jsfiddle.  Which build are you testing with?
Component: HTML: Parser → Layout
QA Contact: parser → layout
I've tested it in Gecko 11 and 12.
This works with Seamonkey trunk but I can see the issue with Firefox 11.
Boris: Are you interested in a "fixed" range in case you want to backport it or should this be closed as wfm ?
I'm guessing bug 726258 fixed this (fx13).  No plans to backport that.
Please reopen if it's still a problem in Fx13 or newer.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 726258
You need to log in before you can comment on or make changes to this bug.