If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Inspector fails to close and behaves weirdly on tab change

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Optimizer, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 617542 [details]
Screenshot displaying the weird behavior

STR :
1) I can reproduce it in more than one site, but for reference go to http://worrydream.com/#!/Tangle
2) Interact with the site a little and then inspect any element.
3) The site seems to reset itself (must be programmed that way) (or inspector causes it)
4) Have the sidebar opened (or even not)
5) Close the inspector by clicking on cross on lower right corner.
6) Change tab/close the current tab
7) Find the side bar still there (if it was visible in step 4)
8) The lower breadcrumbs panel is also there, or if not, reappears on further tab change.
9) The rules and computed sections are empty and when clicked on, produce these errors in error console : 

Timestamp: 4/23/2012 11:21:16 PM
Error: TypeError: tool is undefined
Source File: resource:///modules/inspector.jsm
Line: 1556

Timestamp: 4/23/2012 11:21:40 PM
Error: TypeError: win is null
Source File: resource:///modules/devtools/CssLogic.jsm
Line: 217
(Reporter)

Comment 1

6 years ago
I can also reproduce the same behavior with certain pdf documents when viewed by pdf.js

Comment 2

6 years ago
How do you start the inspector?

Comment 3

6 years ago
For the record, right-clicking on a node that is modified after the resize (something happens on onresize here) throws this error:

Error: TypeError: frameWin is null
Source File: resource:///modules/devtools/LayoutHelpers.jsm
Line: 74
(Reporter)

Comment 4

6 years ago
Right click on the element (or text/image) and select Inspect Element

In both the mentioned pages, the site was fully loaded and nothing resized.

Comment 5

6 years ago
Do you have the same problem when starting the inspector from the Web Dev menu?
(Reporter)

Comment 6

6 years ago
Yes, the problem is due to the sudden disappearance of the selected element. Suppose in an SVG, I right click on a oath that appears only on focus and hover. So as soon as I choose Inspect from context menu, the item disappears (basically gets deleted, invalidated, whatever) So now the inspector breaks. Now if you try to close or switch tab, it acts weirdly and do not gets closed.
It also happens in canvas and other similar situations.

Comment 7

6 years ago
I think this is related to bug 746197.

Updated

5 years ago
Blocks: 762499

Updated

5 years ago
No longer blocks: 762499
Depends on: 762499

Comment 8

5 years ago
This problem can't happen anymore (toolbox).

Bug triage, filter on PINKISBEAUTIFUL
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.