Closed Bug 748029 Opened 8 years ago Closed 7 years ago

Default location bar / search box font is too small and much smaller than other browsers

Categories

(Firefox :: Address Bar, defect, major)

defect
Not set
major

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox14 --- affected

People

(Reporter: briansmith, Assigned: jaws)

Details

Attachments

(3 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #747812 +++
+++ This bug was initially created as a clone of Bug #742419 +++

See the attached screenshot. On my system (Windows 7), the location bar text is only 7px tall (from baseline to cap height) with default windows settings (Smaller / 100% / 72 DPI mode). Comparison:

Firefox: 7px
IE: 11px
Chrome: 10px

IMO, this is a major usability problem. Even with my contact lenses in, I cannot read the location bar on my laptop without leaning in; my laptop has a 15" 1980 x 1080 (1080p) screen. People with 1080p screens of more common sizes like 13" must really have difficulty reading it.

Note that when you switch to "Medium / 125% / 96 DPI mode", the there are other aesthetic problems such as bug 742419.
Brian, when you clone bugs, you also clone their CC lists.

I'm almost certain that this is due to some other configuration in your profile or on your system, but even so, we should try to prevent this from happening. Could you test with a clean profile?
I don't know much about the DPI settings, but there is already bug 625742 filed for increasing the default font size.
Brian, the font size of the tab labels in IE and the identity block in Chrome is really tiny. Are you using some non-default system font setting?
Sorry about the cloning/CC issue. I didn't realize so many people were CC'd.

(In reply to Frank Yan (:fryn) from comment #1)
> Brian, when you clone bugs, you also clone their CC lists.
> 
> I'm almost certain that this is due to some other configuration in your
> profile or on your system, but even so, we should try to prevent this from
> happening. Could you test with a clean profile?

It does happen with a clean profile too.

(In reply to Frank Yan (:fryn) from comment #3)
> Brian, the font size of the tab labels in IE and the identity block in
> Chrome is really tiny. Are you using some non-default system font setting?

It is Segeo UI 8. I checked on some websites and they claim that the default is supposed to be Segeo UI 9, but I didn't change the settings myself so I am not sure. I can redo the comparison with Windows set to Segeo UI 9 if you'd like.
I think as said in bug 625742 the default font size should be increased.
The text size is still smaller than other browsers when Windows is set to default to Segeo UI 9 instead of Segeo UI 8.

If you zoom in on the image I attached, next to the "h" in "https://" you can see the little red marks I used to help measure the number of pixels.

Bug 625742 is about increasing the text size in large font mode. This bug is about the small font mode.
Attachment #617559 - Attachment is obsolete: true
Comment on attachment 617584 [details]
Comparision with Chrome and IE using Windows set to Segeo UI 8 and Segeo UI 9 and 72 DPI mode

Ok, Segoe UI 9 is the same thing that I see on my Windows box.
Yes, it's smaller.
Note that it's the same font-size as the tab labels though.
I actually agree with you that the URL should be larger like Chrome and IE, but my opinion hasn't been shared by enough people for action to be taken yet.
I'll discuss this with other fx-team folks this week.
Attached image Now everything is huge
FYI, I reinstalled Windows from scratch and I noticed that Lenovo seems to have set the default text size to 14pt on their W510 laptops with 1080p screens. Changing Windows's text size to "Medium Text" (125%) results in this HUGE Firefox text, which didn't occur in the rest of the system.
Attachment #636557 - Attachment is patch: false
Attachment #636557 - Attachment mime type: text/plain → image/png
Brian, you mentioned that this might have been fixed a month ago but then regressed. Would you be willing to look through old builds to see if we can find a regression range?
Flags: needinfo?(bsmith)
I haven't written the patch for OS X or Linux yet, but I want to make sure that this would be an acceptable approach.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #738907 - Flags: review?(dao)
Flags: needinfo?(bsmith)
Comment on attachment 738907 [details] [diff] [review]
Patch for Windows

This bug's goal isn't clear to me. Brian's latest report was that everything would be huge now, in which case this patch surely isn't going to make him happy.
(In reply to Dão Gottwald [:dao] from comment #11)
> Comment on attachment 738907 [details] [diff] [review]
> Patch for Windows
> 
> This bug's goal isn't clear to me. Brian's latest report was that everything
> would be huge now, in which case this patch surely isn't going to make him
> happy.

Comment #8 is about a specific bug with out Lenovo ships their computers. I had a similar bug when I got my Lenovo, and had to fix it by changing the DPI to 100%. I don't think that should affect the work in this bug.
s/with out/with how/
What is "this bug"? That we don't increase the location bar text size like other browsers do?

In comment 0, Brian said he was using "Smaller / 100% / 72 DPI mode". But apparently he wasn't using a 72 DPI screen, which means that the usability problem he ran into are pretty much expected and would manifest themselves in many places, not just in the location bar.
(In reply to Dão Gottwald [:dao] from comment #14)
> What is "this bug"? That we don't increase the location bar text size like
> other browsers do?

Yes, other browsers increase this font size while we don't. It makes reading URLs harder in Firefox than other browsers.
Over here IE10 seems to use the same font size. Also, if URLs are hard to read due to the system font size being used, the same would be true for other places in the UI, like tabs.
Hm, I thought IE was also increasing the font but I see that it is the same as Firefox. So basically, the increase in font-size here would have us matching Chrome but not IE.

It's also true that the font size would be larger than what is seen on the tabs, but I'm OK with that. I would like to get some opinion from the UX team on this bug.
Flags: needinfo?(ux-review)
Jared, for an issue like this, I recommend flagging a specific person for needinfo. I shared the bug and my thoughts on this with Limi, and he agreed, so I'm fulfilling the needinfo request here:

If Firefox's UI is failing to scale based on OS DPI/scaling settings, then that should be handled with a patch that keeps Firefox's UI as it currently is with the default scaling setting and fixes Firefox's UI with other settings (e.g. percentage != 100%). This patch changes Firefox's UI for default settings, and that's not a good solution.

Given the above, the bug's title is a bit misleading. Perhaps, we should rename it to reflect what we'd actually want a solution to do.
Flags: needinfo?(ux-review)
Comment on attachment 738907 [details] [diff] [review]
Patch for Windows

Review of attachment 738907 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for investigating and working on this, Jared, but this isn't the right solution.
Attachment #738907 - Flags: review?(dao) → ui-review-
The corollaries here are:

Yes, we think our font sizes for the URL bar, search bar, and tab labels are fine with the 100% scaling. The URL bar font size may be smaller than Chrome's, but Stephen chose that size intentionally.

No, Firefox doesn't perfectly handle scaling factors that are not 100%, but that's a different bug and requires a different fix.

If for whatever reasons OSes are not running in the right DPI mode by default for some hardware, we probably shouldn't try to fix that in Firefox by scaling Firefox differently from other applications. Perhaps, we could help a user adjust the DPI mode in the case that we guess that it's wrong.
Thanks for the feedback Frank.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.