Status

()

defect
RESOLVED DUPLICATE of bug 751320
7 years ago
7 years ago

People

(Reporter: luke, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:-, firefox13-)

Details

(Reporter)

Description

7 years ago
(Spawned from bug 704387 comment 13.)  There is a bug introduced by eaac85c4c05f that is currently breaking a game generated using Mandreel.  (Unfortunately, the game and its sources are not public, but we do have the source if someone else needs it.)

This bug is mainly to track the issue.  I bisected the problem down (from 1.5M lines of JS ;) to a specific switch in a function which, when replaced by an if, fixes the problem so, hopefully this won't be too hard to fix now.
blocking-kilimanjaro: --- → ?
Blocks: WebJSPerf
blocking-kilimanjaro: ? → -
Tracking to fix in Firefox 13 since this is a webcompat regression.
Assignee: general → luke
(Reporter)

Comment 2

7 years ago
I helped bisect, but I'm not the one to fix this.
Assignee: luke → general
Re: this bug and Fx13: given that we don't have a test case, there's no way to work on it directly. But we believe it is the same as bug 751320, so landing those patches (if risk is deemed sufficiently low) seems like the best bet.
No longer blocks: 751320
Blocks: 751320
(Reporter)

Comment 4

7 years ago
Awesome, I can confirm that bug 751320 indeed fixed this problem.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751320
You need to log in before you can comment on or make changes to this bug.