Status

Pancake
Back-end
RESOLVED DUPLICATE of bug 749454
6 years ago
6 years ago

People

(Reporter: st3fan, Assigned: gozer)

Tracking

Details

(Reporter)

Description

6 years ago
Run user-api under SSL. Lets try this on staging and see what the performance is like.

This should be just a matter of generating a certificate for user-api and changing the URLs to https in the config files.

Stefan needs to explain how to set this up so that :gozer can make it happen?

We need to do some speed tests.
(Reporter)

Comment 1

6 years ago
I generated a self signed SSL certificate on play:

1) configured the user-api to run with --ssl --ssl_crt_file and --ssl_key_file
2) changed user_api url in social.json and web.json to point to https instead of http

This works pretty good with minimal performance hit. Let's do this on staging too. Assigning to gozer.
(Reporter)

Updated

6 years ago
Assignee: sarentz → gozer
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749454
You need to log in before you can comment on or make changes to this bug.