Show a nice in-app payment UI when involving PayPal

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
API
P3
normal
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: kumar, Assigned: potch)

Tracking

unspecified
2012-06-07
x86
Mac OS X

Details

(Whiteboard: [ye-olde-paypal])

In a few less common cases, the buyer will need to enter the PayPal UI to complete an in-app payment. These cases are described here https://bugzilla.mozilla.org/show_bug.cgi?id=746460#c4

The UI for this currently isn't pretty. It involves many nested iframes, something like this: http://cl.ly/3y0q1c2A3U0M1n0J3L3K

We should make this slightly more pretty! i.e. user friendly.
Blocks: 698116
Priority: -- → P3
Target Milestone: --- → 6.5.3
-> potch for the week after we get back
Assignee: nobody → thepotch
Target Milestone: 6.5.3 → 6.5.4
(Assignee)

Comment 2

6 years ago
We are explicitly not allowing paypal in the in-app flow. Users should never have to deal with iframe inception. We can gracefully fail in these corner cases, and strive to avoid them.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
If we decide to wontfix it then we need to change the code :) https://github.com/mozilla/zamboni/blob/master/mkt/inapp_pay/views.py#L151 <- that will trigger the wonky iframe in today's in-app flow. Here is a list of scenarios that will trigger it: https://bugzilla.mozilla.org/show_bug.cgi?id=746460#c4

Maybe we should display an error message like 'we have experienced an unexpected error with PayPal' instead?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 4

6 years ago
yes, that makes much sense :) didn't realize we still had cases where this triggered.
Duplicate of this bug: 755091
Target Milestone: 2012-05-10 → 2012-05-31
Target Milestone: 2012-05-31 → 2012-06-07
Whiteboard: [ye-olde-paypal]
I assume this can be WONTFIX'd?
Yep. The new UI will be part of bug 794651
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.