Last Comment Bug 748269 - Extension block request: anttoolbar@ant.com
: Extension block request: anttoolbar@ant.com
Status: RESOLVED FIXED
[extension]
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 750330
Blocks: 640904
  Show dependency treegraph
 
Reported: 2012-04-24 01:25 PDT by Scoobidiver (away)
Modified: 2016-03-07 15:30 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Scoobidiver (away) 2012-04-24 01:25:41 PDT
Extension name: Ant Video Downloader and Player
Extension UUID: anttoolbar@ant.com
Extension versions to block: 2.4.6.4 and below
Applications, versions, and platforms affected affected: All Fx versions
Block severity: (hard/soft) soft

Homepage, AMO listing, other references and contact info: 

Reasons:
It's responsible of 1693 crashes per day in Fx 11 (with a 10% throttle) and 2352 crashes per day in Fx 12. For more, see bug 640904.
Comment 1 Jorge Villalobos [:jorgev] 2012-04-25 09:59:21 PDT
Adding Brian for feedback.
Comment 2 Brian King [:kinger] 2012-04-26 08:36:53 PDT
I think it would be unfair to block it as the cause is 3rd party software and not the add-on. See bug 733892.
Comment 3 Jorge Villalobos [:jorgev] 2012-04-26 08:42:56 PDT
As far as I know, that's a different crash. The correlations in bug 640904 should have shown Avast if that were the case. Adding Marcia and Kairo for confirmation.
Comment 4 Robert Kaiser 2012-04-26 09:09:16 PDT
We should not block here unless we have contacted them and they are unresponsive to that and not shipping a fix - or they have agreed to a block. I'm not even sure yet if we know at all if Ant is the cause here.
Comment 5 Jorge Villalobos [:jorgev] 2012-04-26 14:07:48 PDT
Kairo: Brian works on the Ant extension. That's the reason I added him to the discussion.
Comment 6 Jorge Villalobos [:jorgev] 2012-04-26 14:15:31 PDT
(In reply to Brian King (Briks) [:kinger] from comment #2)
> I think it would be unfair to block it as the cause is 3rd party software
> and not the add-on. See bug 733892.

Brian: bug 640904 is currently the #1 crasher on Mac OS, so I don't think this is related to 3rd party software. Also, it looks like this is only correlated to your latest version.

Is it possible for you to submit an update that rolls back to the previous public version? It will be useful for us to make sure that this is the cause of the crash and to mitigate the problem. Please note that this is holding back the Firefox 12 update, so this is very urgent.
Comment 7 Jorge Villalobos [:jorgev] 2012-04-26 15:06:14 PDT
I have downgraded the latest version for now, to mitigate the problem for users on old versions.
Comment 8 Marcia Knous [:marcia - use ni] 2012-04-26 16:26:02 PDT
Current manual correlations for Firefox 12 on Mac:

Mac OS X
  JSAutoEnterCompartment::enter|EXC_BAD_ACCESS / KERN_INVALID_ADDRESS (291 crashes)
     96% (279/291) vs.  19% (343/1849) anttoolbar@ant.com (Ant.com Toolbar - Tube Downloader, https://addons.mozilla.org/addon/8174)
          0% (1/291) vs.   0% (4/1849) 2.4.5
          6% (17/291) vs.   2% (29/1849) 2.4.6.2
         90% (261/291) vs.  17% (310/1849) 2.4.6.4
     28% (82/291) vs.  13% (242/1849) {b9db16a4-6edc-47ec-a1f4-b86292ed211d} (Video DownloadHelper, https://addons.mozilla.org/addon/3006)
          0% (1/291) vs.   0% (3/1849) 4.9.7
          1% (2/291) vs.   1% (11/1849) 4.9.8
         27% (79/291) vs.  12% (228/1849) 4.9.9
     12% (34/291) vs.   3% (59/1849) {19503e42-ca3c-4c27-b1e2-9cdb2170ee34} (FlashGot, https://addons.mozilla.org/addon/220)
          1% (4/291) vs.   0% (8/1849) 1.4.1
         10% (30/291) vs.   3% (51/1849) 1.4.3
     12% (35/291) vs.   4% (72/1849) {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} (Easy YouTube Video Downloader, https://addons.mozilla.org/addon/10137)
          0% (1/291) vs.   0% (1/1849) 5.7
         12% (34/291) vs.   4% (71/1849) 5.9
     11% (33/291) vs.   3% (60/1849) artur.dubovoy@gmail.com (Flash Video Downloader, https://addons.mozilla.org/addon/6584)
          0% (1/291) vs.   0% (1/1849) 3.2.0
          0% (1/291) vs.   0% (4/1849) 3.5.6
          0% (1/291) vs.   0% (1/1849) 3.5.8
          0% (1/291) vs.   0% (1/1849) 3.5.9
         10% (29/291) vs.   3% (53/1849) 3.6.0
     38% (111/291) vs.  30% (559/1849) testpilot@labs.mozilla.com (Mozilla Labs - Test Pilot, https://addons.mozilla.org/addon/13661)
          0% (0/291) vs.   0% (1/1849) 1.0.3
          0% (1/291) vs.   0% (6/1849) 1.1.2
          0% (0/291) vs.   0% (2/1849) 1.1.3
          0% (1/291) vs.   2% (40/1849) 1.2
         37% (109/291) vs.  28% (510/1849) 1.2.1
     10% (29/291) vs.   2% (38/1849) video.downloader.plugin@ffpimp.com (Download YouTube Videos +, https://addons.mozilla.org/addon/12984)
          0% (0/291) vs.   0% (2/1849) 12.8
         10% (29/291) vs.   2% (36/1849) 12.9.6
     14% (40/291) vs.   7% (132/1849) {23fcfd51-4958-4f00-80a3-ae97e717ed8b}
          2% (6/291) vs.   1% (20/1849) 2.1.2.126
         12% (34/291) vs.   6% (112/1849) 2.1.2.145
     20% (58/291) vs.  14% (267/1849) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
          0% (0/291) vs.   0% (2/1849) 1.3.10
          0% (1/291) vs.   0% (1/1849) 2.0.2
         20% (57/291) vs.  14% (263/1849) 2.0.3
          0% (0/291) vs.   0% (1/1849) 2.0.4b.3445
      7% (20/291) vs.   2% (28/1849) {bee6eb20-01e0-ebd1-da83-080329fb9a3a}
          0% (0/291) vs.   0% (3/1849) 1.06
          0% (1/291) vs.   0% (2/1849) 1.07
          7% (19/291) vs.   1% (23/1849) 1.08
Comment 9 Scoobidiver (away) 2012-04-27 00:56:13 PDT
It's also #1 top crasher on Windows in 12.0 with 9% of all crashes. Here are correlations per extension:
  JSAutoEnterCompartment::enter(JSContext*, JSObject*)|EXCEPTION_ACCESS_VIOLATION_READ (6703 crashes)
     90% (6060/6703) vs.   9% (6451/73266) anttoolbar@ant.com (Ant.com Toolbar - Tube Downloader, https://addons.mozilla.org/addon/8174)
          0% (4/6703) vs.   0% (6/73266) 2.4.5
          3% (223/6703) vs.   0% (237/73266) 2.4.6.2
          0% (2/6703) vs.   0% (2/73266) 2.4.6.3
         87% (5831/6703) vs.   8% (6206/73266) 2.4.6.4
Comment 10 Alex Keybl [:akeybl] 2012-04-30 14:34:15 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #7)
> I have downgraded the latest version for now, to mitigate the problem for
> users on old versions.

When do we plan to call it a day and block version 2.4.6.4? This may prevent us from fully unthrottling updates to FF12 until it's resolved.
Comment 11 Jorge Villalobos [:jorgev] 2012-04-30 15:08:02 PDT
Brian: the latest version of the Ant.com Toolbar will be blocked first thing tomorrow unless you upload version 2.4.6.2 as 2.4.6.5 so that current users are reverted to a stable version.
Comment 12 Jorge Villalobos [:jorgev] 2012-05-01 10:35:13 PDT
Blocked: https://addons.mozilla.org/en-US/firefox/blocked/i88
However, it looks like this is also being blocked by bug 750330.
Comment 13 Brian King [:kinger] 2012-05-01 13:09:43 PDT
I have been on vacation and missed this conversation. I will be working on a fix for this immediately.

Where can I find more information to help me track this down (have not been able to reproduce so far)?
Comment 14 Jorge Villalobos [:jorgev] 2012-05-01 14:05:23 PDT
Brian: first we need you to do what I asked for in comment #11. If you do that, I can temporarily remove the block to facilitate user updates and avoid confusion.

As for getting more info, you should look at bug 640904 and ask there if necessary.

Calling this fixed since the block is in place.
Comment 15 Brian King [:kinger] 2012-05-02 04:32:42 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #14)
> Brian: first we need you to do what I asked for in comment #11. If you do
> that, I can temporarily remove the block to facilitate user updates and
> avoid confusion.

Done. 2.4.6.5 should be in the review queue.
Comment 16 Jorge Villalobos [:jorgev] 2012-05-02 09:01:22 PDT
Brian, the file you uploaded is based off of 2.4.6.4, not 2.4.6.2.
Comment 17 Brian King [:kinger] 2012-05-02 11:02:18 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #16)
> Brian, the file you uploaded is based off of 2.4.6.4, not 2.4.6.2.

Sorry about that. I deleted that version and uploaded a new 2.4.6.5.
Comment 18 Jorge Villalobos [:jorgev] 2012-05-02 11:42:23 PDT
The update has been approved.

I'm not sure where that puts us in terms of the block. We might need to keep it up in order to mitigate the crashes in the short term. Alex, what do you think?
Comment 19 Brian King [:kinger] 2012-05-10 04:00:31 PDT
FYI...

I have uploaded a new version, 2.4.7, which in our tests at least fixes the crash issue.

Please consider for a quick review.
Comment 20 Alex Keybl [:akeybl] 2012-05-23 18:04:36 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #18)
> The update has been approved.
> 
> I'm not sure where that puts us in terms of the block. We might need to keep
> it up in order to mitigate the crashes in the short term. Alex, what do you
> think?

Let's just leave the block up since the new version will doesn't fall into the block range. If the top crasher is reintroduced at some point, we can revisit.

Note You need to log in before you can comment on or make changes to this bug.