nsLineLayout::RecordWordFrame inefficient

RESOLVED DUPLICATE of bug 129167

Status

()

RESOLVED DUPLICATE of bug 129167
18 years ago
16 years ago

People

(Reporter: bratell, Assigned: attinasi)

Tracking

({perf})

Trunk
mozilla1.2alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I was looking at profiles for the URL 
http://www.javasoft.com/j2se/1.3/docs/api/index-files/index-7.html which is slow 
in Mozilla and noticed that we store text frames in a nsVoidArray when 
calculating text width. 

That's probably right, but we do it in an inefficient way so that this single 
function is a whole percent of the total time for the page. The problem is that 
every nsLineLayout::RecordWordFrame causes a nsVoidArray::InsertElementAt which 
causes a new and memory allocations are expensive in Mozilla. Is it possible to 
reserve space in the array to begin with, or grew it in bigger chunks than one 
at a time?
(Reporter)

Updated

18 years ago
Keywords: perf

Comment 1

18 years ago
line layout => reassigned to attinasi
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Updated

17 years ago
Keywords: mozilla1.0
What's the status of this bug ? There hasn't been any activity since 04/2001. Is
Marc Attinasi (bug owner) still working on Mozilla ? I can't find any recent
comment from him in Mozilla.
The nsVoidArray got replaced with an nsDeque, which uses progressive doubling,
in bug 129167.

*** This bug has been marked as a duplicate of 129167 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.