Removing dropdown arrows in Firefox bookmark toolbar on Linux

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
6 years ago
a day ago

People

(Reporter: luigitedone@gmail.com, Unassigned)

Tracking

14 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The folder icons in the bookmark toolbar of firebox contain a down arrow
for indicating a submenul. They should not contain a down-arrow like in Firefox version for Windows.

Reproducible: Always

Steps to Reproduce:
1. Add a folder to bookmark toolbar


Actual Results:  
You get an icon with a down arrow.

Expected Results:  
Show only the folder icon and the label without the dropdown arrow.

Comment 1

6 years ago
I have the same issue, except it occurs when I put two RSS feeds on the bookmark toolbar and move it to the right of the home button (then I get rid of the toolbar).   If that doesn't create the drop down, then turning off the menu toolbar will.

Again this issue is non-existant in Windows.

I can also reproduce the original issue.   The bookmarks toolbar seems to aggressively want a drop down arrow only on linux.  In fact even in the "customize toolbar" screen it shows the drop down.
I think this was an intended design based on Linux style guides, we should verify if current Linux versions are still using that common style.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

5 years ago
Created attachment 712789 [details]
two different arrows

It occurred to me via the last comment that I might have a different issue.  This screenshot might demonstrate both issues.

The far right double arrows is the problem I am seeing.  Firefox aggressively adds that even when it's not needed (the only bookmark hidden under the >> is just 1 character long).

If this bug is about the other arrow after Most Visited.  I was unable to find any information in the GNOME Human Interface Guidelines one way or the other.  Some example applications that do have a similar drop down arrow to this: Archive Manager (the closest, but the dropdown is distinct from the open button).  Gnome's calculator (but it's not a folder),   LibreOffice has both of these arrows in it.
Not sure it would be removed but it is absolutely essential on the Bookmarks button when you have the menu off.
I just tested this on ubuntu with a Firefox 59 nightly, and there's no arrow on the folder for the drop down.
Status: NEW → RESOLVED
Last Resolved: a day ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.