If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

marking thread/all read needs to invalidate collapsed thread(s) having unread children

RESOLVED FIXED in mozilla1.4beta

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Christian Eyrich)

Tracking

Trunk
mozilla1.4beta
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.33 KB, patch
neil@parkwaycc.co.uk
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
mark all read can leave the outliner needed an invalidate

more details on the way..
to reproduce:

have a thread, and the top level message is read, but there are unread children.
collapse the thread.

do "mark all read".

we need to invalidate the outliner row for the thread parent, since the icon
should change and so should the unread thread counts.
Status: NEW → ASSIGNED

Updated

17 years ago
QA Contact: esther → fenella

Updated

16 years ago
QA Contact: fenella → laurel

Comment 2

16 years ago
*** Bug 116898 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
I don't understand the summary.

Bug 113000 might be a dupe.

pi

Comment 4

16 years ago
Yes, Bug 113000 is probably a dupe of this one.
For sure my bug 116898 is a dupe of this one.

Comment 5

16 years ago
*** Bug 113000 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 91107 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 162503 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: mark all read can leave the outliner needed an invalidate → marking thread/all read needs to invalidate collapsed thread(s) having unread children

Comment 8

15 years ago
*** Bug 132622 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

15 years ago
Created attachment 119307 [details] [diff] [review]
Proposed patch

For an explanation of this patch see bug 132622, comment 6.
This patch has been changed to eliminate double notify in case of the first
message of the thread.

Updated

15 years ago
Attachment #119307 - Flags: superreview?(sspitzer)
Attachment #119307 - Flags: review+
looks good, re-assign for proper credit
Assignee: sspitzer → ch.ey
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla1.4beta
Comment on attachment 119307 [details] [diff] [review]
Proposed patch

sr=sspitzer.  thanks for the patch (and to neil, for the review)

neil, can you land this?
Attachment #119307 - Flags: superreview?(sspitzer) → superreview+

Comment 12

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.