Dont sync about: pages from fennec to other devices

RESOLVED DUPLICATE of bug 718153

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 718153
6 years ago
2 months ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 617864 [details]
screenshot

for sites bookmarked on about:___ on fennec (about:home, about:firefox), we shouldnt be syncing these to other devices.   there's no syncing about: pages from firefox desktop -> fennec, so it doesnt makes sense to do the opposite.

We're currently allowing syncing fennec about: pages -> desktop or other phones.

Screenshot on desktop of mobile bookmarked about: sites

Repro:
1) install 04-24-2012 nightly, HTC Incredible S
2) pair fennec and desktop via sync
3) bookmark a few about: pages on fennec (about:home, about:firefox)
4) trigger sync
5) verify on desktop firefox, the about: pages bookmarked on fennec appear on desktop firefox.

Expected:
- dont need to sync about: pages from fennec to desktop

Actual;
- about: pages sync'd
(Reporter)

Updated

6 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM
This is very easy to do if we decide to.
I don't recall the reason about pages are filtered from syncing by desktop. Also, are there about pages on mobile that aren't supported on desktop or vice versa?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718153
(Reporter)

Comment 4

6 years ago
(In reply to Tracy Walker [:tracy] from comment #2)
> I don't recall the reason about pages are filtered from syncing by desktop.
> Also, are there about pages on mobile that aren't supported on desktop or
> vice versa?

yes.  about:firefox and about:home on Mobile has much different content than on desktop.    same for about:crashes, as those stacks would only pertain to fennec, and not desktop.
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

2 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.