[One Mozilla] Migrate remaining /contribute pages to Bedrock

RESOLVED DUPLICATE of bug 885896

Status

RESOLVED DUPLICATE of bug 885896
6 years ago
5 years ago

People

(Reporter: davidwboswell, Assigned: sgarrity)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Currently only the main /contribute page has been migrated to Bedrock, but there are other pages in that section that we'd also want to move over as well.  Opening bug to track that.

Note: some pages on the legacy www.mozilla.org site in that section can be removed instead of migrated.  

* The /contribute/thanks.html file won't be needed once all pages are migrated since that's just used by the legacy lead generation form.  The new lead generation form has the Thank You message inline and not on a separate page.

* The /contribute/timeavailable.html file won't be migrated since we're no longer providing that as a link from the new Get Involved page.

Some of these pages may need to be redesigned to fit in with the new site design, such as the regional maps.  Other pages, like the Areas of Interest can be moved over as is.

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Summary: Migrate remaining /contribute pages to Bedrock → [One Mozilla] Migrate remaining /contribute pages to Bedrock
Target Milestone: --- → Future

Updated

6 years ago
Assignee: nobody → steven
Target Milestone: Future → 2.7
Created attachment 624568 [details]
Descriptions of items in help form

Instead of migrating the content to a different section of the page, we can merge the descriptions into the Help form (see attachment) to reflect the option selected from the drop down menu. Saving space and being to the point :)
Comment under captcha in the attachment should say "to the left" and not to the right.
(Assignee)

Comment 3

6 years ago
David, it seems the remaining pages are: 

http://www.mozilla.org/contribute/areas.html
Will this remain as a stand-alone page, or should this longer list of interests be added to the list already on /contribute/ ?

http://www.mozilla.org/contribute/local/
and the regional sub-pages, like http://www.mozilla.org/contribute/local/northamerica.html

The /contribute/local/ page seems to be obsoleted by the /contribute/ page. How about the regional pages? Should they be ported as-is, or are they being replaced by Mozilla Spaces work?
(Reporter)

Comment 4

6 years ago
(In reply to Steven Garrity from comment #3)
> http://www.mozilla.org/contribute/areas.html
> Will this remain as a stand-alone page, or should this longer list of
> interests be added to the list already on /contribute/ ?

There is still a need for a stand-alone list of areas for now, so I'd like to move the page over.  

Pierros has some ideas for how to integrate the full list into the main Get Involved page that we can look at in a design update of the page later.  I don't think just making the Interest section longer will be that useful.

For the page content, we can take just the information in the main content area of the current page and not worry about the sub-nav and lead generation in the current page's side nav.  

Basically it could look like a longer version of the Interest area on the main page with a paragraph of text at the top.

> http://www.mozilla.org/contribute/local/
> and the regional sub-pages, like
> http://www.mozilla.org/contribute/local/northamerica.html
> 
> The /contribute/local/ page seems to be obsoleted by the /contribute/ page.

It's fine to replace the /contribute/local page if we could point people directly to this content on the /contribute page.

When I click on the 'Location' tab, I get something that looks like an anchor link:

http://www.mozilla.org/en-US/contribute/#location

It doesn't seem to function as an anchor link though -- clicking on that takes me to the top of the page.  Anyway to make that a real anchor?

> How about the regional pages? Should they be ported as-is, or are they being
> replaced by Mozilla Spaces work?

There's a little bit of overlap with Spaces work, but this covers much more location specific information than just offices.

I think it probably would also be a good idea to take this chance to rethink the design and layout of the page.  For instance, how would the maps work in a responsive design setting?  Where would the lead generation form go without a sidebar?

Would you recommend that we open a design bug for this before trying to move the pages over?

Updated

6 years ago
Target Milestone: 2.7 → Future
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

5 years ago
Component: General → Pages & Content
Is this a dupe of 885896?

Even if it isn't a dupe, can we move forward with it now that the new contact us page is live?

Thx!
Flags: needinfo?(steven)
Flags: needinfo?(dboswell)
Flags: needinfo?(booboobenny+bugzilla)

Comment 6

5 years ago
Based on the original comment to me this looks like a dupe as Jenn mentions.

If anyone thinks this is incorrect - please re-open.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(booboobenny+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 885896
(Assignee)

Updated

5 years ago
Flags: needinfo?(steven)
(Reporter)

Updated

5 years ago
Flags: needinfo?(dboswell)
You need to log in before you can comment on or make changes to this bug.