If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow overdraw of glyphs so that we're faster on mobile

RESOLVED DUPLICATE of bug 754872

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 754872
6 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Currently, we try to avoid overcompositing overlapping glyphs by building a mask of all the glyphs. We don't do this on all platforms (OS X) and can probably get away with not doing it on mobile.


See for example:
http://people.mozilla.com/~jmuizelaar/implementation-tests/overlapping-glyphs.html
(Reporter)

Updated

6 years ago
Blocks: 717774
(Reporter)

Comment 1

6 years ago
Created attachment 618149 [details] [diff] [review]
Ignore glyph overlap

This patch should do the trick
(Reporter)

Updated

6 years ago
Whiteboard: [autoland]
Whiteboard: [autoland] → [autoland-try]

Updated

6 years ago
Whiteboard: [autoland-try] → [autoland-in-queue]

Comment 2

6 years ago
Autoland Patchset:
	Patches: 618149
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=0a237c7aee26
Try run started, revision 0a237c7aee26. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=0a237c7aee26
(Reporter)

Updated

6 years ago
Whiteboard: [autoland-in-queue] → [autoland-try -b do -p all -u all -t all]
(Reporter)

Updated

6 years ago
Whiteboard: [autoland-try -b do -p all -u all -t all] → [autoland-try: -b do -p all -u all -t all]
(Reporter)

Comment 3

6 years ago
Created attachment 619336 [details] [diff] [review]
Same as last time
Attachment #618149 - Attachment is obsolete: true
Whiteboard: [autoland-try: -b do -p all -u all -t all]
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754872
You need to log in before you can comment on or make changes to this bug.