modern theme rendering incomplete

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: tracy, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
seen on commercial builds:

windows 2001-04-05-06-trunk (as brief as i was able to see it)
linux 2001-04-05-05-trunk
mac 2001-04-05-04-trunk

modern theme seems to have classic mixed in...ie. some tool bars are grey 
instead of blue...missing search button (it is selected in prefs)...missing "v" 
in URL bar to call history pop up window
(Assignee)

Comment 1

18 years ago
This only happens after a theme switch... I'm certain this is a dup of another
bug.  
(Reporter)

Comment 2

18 years ago
hewitt,
what I am seeing also happens with a new profile, no theme switch.

Comment 3

18 years ago
On Mac (2001-04-05-04-Mtrunk), it never ask you to creat a new profile or
use the old profile at all, it automatically launches it. Yes, the modern
theme is missing home, bookmark, search features, etc...

On windows (2001-04-05-05-Mtrunk), the browser crashes after the installation.
Tracy, did you able to see it on windows?

On Linux (2001-04-05-08-Mtrunk), the modern theme is missing home, bookmark,
search features, etc...

Comment 4

18 years ago
Tracy,

On windows (2001-04-05-05-Mtrunk), I meant the browser quits after the 
installation, not crash.

(Assignee)

Comment 5

18 years ago
Since I have not checked anything in recently, I don't know what is causing this
to happen.  I see that made some changes for bug 53670 which may be causing
this.  Waddya think, hyatt?
(Assignee)

Comment 6

18 years ago
Figured this one out with Hyatt. This bug actually only affects users of
Netscape 6 using the Modern theme.  The problem is that the commercial
themes/modern/global/contents.rdf was not updated to sync with Hyatt's new skin
versioning.  Patch coming soon.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
Created attachment 29971 [details] [diff] [review]
patch to fix

Comment 8

18 years ago
Bad news... I just saw this with a Mozilla build... no Netscape 6 build involved.

Skin-switching explicitly to Modern solved the problem for me, but when I first
launched the new build after it finished, I was in this weird mixed state.

Anyway, sr=hyatt on your fix, but I'm not sure it solves everything.

Comment 9

18 years ago
No luck with this, i still see mixed modern & classic.
and here I was thinking this was the exciting new skin we've heard much about!

r=ben
(Assignee)

Comment 11

18 years ago
*** Bug 75231 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

18 years ago
I checked in the fix for netscape modern.  Since hyatt claims he's still seeing
this symptom in Mozilla, I'll keep this bug open for a while until we're certain
the problem is fixed.
(Reporter)

Comment 13

18 years ago
fixed on commercial builds:

windows 2001-04-10-06-trunk
linux 2001-04-10-05-trunk
mac 2001-04-10-04-trunk

leaving open per hewitts comment

(Assignee)

Comment 14

18 years ago
seems to be ok now
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

18 years ago
verified fixed

commercial builds:

windows 2001-04-11-06-trunk
linux 2001-04-11-05-trunk
mac 2001-04-11-09-trunk
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.