Status

Websites
other.mozilla.org
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: icaaq, Assigned: icaaq)

Tracking

Details

(Assignee)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120424 Firefox/14.0a1
Build ID: 20120424075151

Steps to reproduce:

1. Press Cmd+N to open a new browser window, then type http://support.mozilla.org/en-US/search?e=es&product=desktop&q_tags=desktop&q=desktop in the address bar and press Enter
2. Tab yourself to the title of the first searchresult
3. Tab once more


Actual results:

Focus is set to a redundant link, same href as the title link


Expected results:

Focus should be set to the next searchresult
(Assignee)

Comment 1

6 years ago
Keyboard users navigate between interactive elements via the Tab key. Every anchor element creates a tab stop, so redundant links within a module can create an inefficient overall tab flow, making navigating with the Tab key a real drag for keyboard users.

More info on this http://yaccessibilityblog.com/library/easy-fixes-to-common-accessibility-problems.html#dupe-links
https://github.com/mozilla/kitsune/commit/39e6f7a1f1380095be6eb2196d093238551fe97a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → icaaaq
You need to log in before you can comment on or make changes to this bug.