Closed Bug 748585 Opened 8 years ago Closed 8 years ago

Java low res screenshot sometimes renders black

Categories

(Firefox for Android :: General, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox14 --- fixed
blocking-fennec1.0 --- beta+

People

(Reporter: jpr, Assigned: blassey)

References

Details

(Whiteboard: [inbound])

Attachments

(1 file)

Post bug 746016, occasionally you will get regions of the screen that checkboard black.  If you wait for the screenshot to update (a few seconds) it seems to be resolved.
Attached patch patchSplinter Review
Attachment #618088 - Flags: review?(bugmail.mozilla)
Comment on attachment 618088 [details] [diff] [review]
patch

Review of attachment 618088 [details] [diff] [review]:
-----------------------------------------------------------------

I'm a bit wary of the performance implications of this, but let's get it in and fix it up later/back out if it's an issue.
Attachment #618088 - Flags: review?(bugmail.mozilla) → review+
Blocks: 746016
Duplicate of this bug: 748487
https://hg.mozilla.org/mozilla-central/rev/6a8ef70e44b5
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 748693
Duplicate of this bug: 748748
This seems to be fixed on 04-25-2012 inbound.  i dont see any more black flashing from the tests in the duped bugs.
(In reply to Tony Chung [:tchung] from comment #8)
> This seems to be fixed on 04-25-2012 inbound.  i dont see any more black
> flashing from the tests in the duped bugs.

I cannot reproduce it either on Samsung Galaxy S (2.2) using the latest inbound build.
Comment on attachment 618088 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #618088 - Flags: approval-mozilla-aurora?
Comment on attachment 618088 [details] [diff] [review]
patch

Mobile only, clean up for bug 746016
Attachment #618088 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
None of the issues duplicated after this bug are reproducible. Marking as Verified.

Verified on:
Aurora 14.0a2 2012-04-29
Nightly 15.0a1 2012-04-30
Device: HTC Device
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.