PSM, then browser crashes on SSL sites (w/proxy?)

VERIFIED DUPLICATE of bug 75865

Status

VERIFIED DUPLICATE of bug 75865
18 years ago
2 years ago

People

(Reporter: asim, Assigned: ddrinan0264)

Tracking

1.0 Branch
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (WinNT; U)
BuildID:    2001040404 (duplicated in 2001040504)

Using build 2001040404 & 2001040504 -- Going to any SSL site (logging into 
Hotmail.com, https://www.springmail.com, using my bank's online services, 
logging into my ISP's web forms) crashes PSM, and then produces this message in 
the browser window:

"Host Required in Request
 
Description: Your browser did not send a hostname as part of requested the url. 
The configuration of this proxy requires a hostname to sent as part of the url"

After that message, Mozilla either locks up or goes to 95%+ CPU time (PII 450). 
Have removed and reinstalled, and I am behind a proxy, accessed through an IP 
address (and manually set). My platform is WinNT SP6.

Reproducible: Always
Steps to Reproduce:
1. Start up build 2001040404 (behind proxy?)
2. Go to https://www.springmail.com

Actual Results:  First PSM crashes, then browser pops up error, then Mozilla 
dies or takes up almost all the CPU.

Expected Results:  Opened up SSL-secured web site

WinNT SP6

Comment 1

18 years ago
the same happens on linux, build 2001040508, this should be a blocker...!?
->Crypto
Assignee: mstoltz → ddrinan
Component: Security: General → Security: Crypto
QA Contact: ckritzer → junruh

Comment 3

18 years ago
I experience the same problem. I am also on WinNT 4 Sp6a and I am behind a
firewall/proxy. This is definitely a blocker for me. It is realy frustrating me
to continually see the SSL capabilaties of Mozilla broken, especially when
behind a proxy :-(
(Reporter)

Comment 4

18 years ago
Actually, since the initial proxy SSL problems were fixed, this is the first 
diffculity I've had.

Additional info:
Tested it on my home system, which is not behind a proxy, just a firewall. 
Running Win2K, SP1 (Dual PII 350). Grabbed build 2001040520 and installed it, 
then tried logging in at http://www.hotmail.com and https://www.springmail.com 
with success.
Then turned on Internet Junkbuster Proxy on my PC, and configured both Mozilla 
and IE 5.5 to use the Junkbuster. Re-tried https://www.springmail.com, Mozilla 
did _not_ crash, but came up with screen that had only this:
<html><body></body></html>
This is also exactly what shows up in Mozilla's "view source" document. IE 
rendered it fine. Also tried logging it at http://www.hotmail.com, but could 
not due to unrelated problems with Junkbuster dealing with Hotmail's SLL/cookie 
setup and redirect.
So, to reproduce:
1) Go to https://www.springmail.com in Mozilla, outside of a proxy, and see if 
it comes up (be careful you do not go to http://www.springmail.com -- they look 
very much alike)
2) Get behind a proxy, or simply go and and install a copy of a proxy 
(Junkbusters can be found at http://www.junkbusters.com/ )
3) Configure Mozilla to use the proxy
4) Go to https://www.springmail.com

You should get a screen with just the HTML tags showing, as above.
Hope this helps!

Comment 5

18 years ago
using the last couple of nightly builds, I get a PSM failure, but not
a browser crash. (ATM I'm running build 2001041200)

Comment 6

18 years ago
the last problem with junkbuster is dup of bug 75865

Comment 7

18 years ago
Since there is no longer a crash, marking this a dupe of bug 75865.

*** This bug has been marked as a duplicate of 75865 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
corected URL scheme...

Comment 10

17 years ago
Mass changing Security:Crypto to PSM
Component: Security: Crypto → Client Library
Product: Browser → PSM
Version: other → 2.1

Comment 11

17 years ago
Mass changing Security:Crypto to PSM

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.