If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Modify tcheckerboard and tcheck2 to provide a cumulative checkerboard score instead of an average

RESOLVED DUPLICATE of bug 746215

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 746215
6 years ago
6 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

:wlach pointed out that computing the average checkerboarded area per frame may not be the best way to measure checkerboarding. If you have run 1 which has 10 frames, one of which is checkerboard, that will give a different result from run 2 which has 11 frames with one checkerboard. Really both of these have the same amount of checkerboard, so the score should be the same but with our current metric we'd get 0.90 for the first one and 0.91 for the second one. Eideticker just takes the sum of all the checkerboard across all the frames which guards against this issue. Should we change tcheckerboard and tcheck2 to also do this?
interesting.  Would this be a change inside of testCheckerboard and testCheck2?  

Currently Talos runs each test 5 times and then take an average of the numbers produced.  I want to make sure we are talking about the same thing here.
Yes, this would change the code in FennecNativeDriver's stopCheckerboardRecording method to sum the checkerboard percentages instead of averaging them.
During the sync-up today we decided to do this, so I'm going to dupe it to bug 746215 and do it all as one patch.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746215
You need to log in before you can comment on or make changes to this bug.