View Page source causes an illegal operation in XPCOM.DLL

VERIFIED DUPLICATE of bug 74728

Status

()

--
critical
VERIFIED DUPLICATE of bug 74728
18 years ago
14 years ago

People

(Reporter: mrous, Assigned: erik)

Tracking

({crash, intl})

Trunk
crash, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    00000000 - Bidi build dated 20010404

Trying to view the source of an html page no matter what the encoding is causes 
an illegal operation in XPCOM.DLL

Reproducible: Always
Steps to Reproduce:
1.Open file Ken.htm
2.From the View Menu, select Page Source

Actual Results:  MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:10011249.
Registers:
EAX=01f42a98 CS=0167 EIP=10011249 EFLGS=00010246
EBX=0106a51c SS=016f ESP=0070f77c EBP=0070f98c
ECX=00000020 DS=016f ESI=01f42a98 FS=743f
EDX=00000020 ES=016f EDI=000000dc GS=0000
Bytes at CS:EIP:
8b 01 85 c0 74 1b 8b 74 24 08 3b 30 74 05 8d 48 
Stack dump:
01f42a98 100112da 000000dc 01043576 01f42a98 000000dc 10010f50 0070f954 
01056a89 01f42a98 00000004 01f42a98 0070f954 01056735 019023b0 0105ac65 

Expected Results:  Mozilla should open the HTML source of the file
(Reporter)

Comment 1

18 years ago
Created attachment 29843 [details]
File attached to reproduce the view source problem

Comment 2

18 years ago
Got it with www.mozilla.org too. Linux, 2001040414.

Traceback:

(gdb) where
#0  0x40091901 in nsFixedSizeAllocator::FindBucket ()
   from /home/cesarb/mozilla/libxpcom.so
#1  0x400919e3 in nsFixedSizeAllocator::Free ()
   from /home/cesarb/mozilla/libxpcom.so
#2  0x40934ac7 in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#3  0x409345ca in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#4  0x4093c886 in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#5  0x409325b3 in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#6  0x409323f9 in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#7  0x40932cdc in NSGetModule ()
   from /home/cesarb/mozilla/components/libhtmlpars.so
#8  0x4097247f in NSGetModule ()
   from /home/cesarb/mozilla/components/liburiloader.so
#9  0x408b6912 in NSGetModule ()
   from /home/cesarb/mozilla/components/libnecko.so
#10 0x408b4928 in NSGetModule ()
   from /home/cesarb/mozilla/components/libnecko.so
#11 0x40872fda in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
   from /home/cesarb/mozilla/components/libnecko.so
#12 0x4087237c in NSGetModule ()
   from /home/cesarb/mozilla/components/libnecko.so
#13 0x400bfeb7 in PL_HandleEvent () from /home/cesarb/mozilla/libxpcom.so
#14 0x400bfdd6 in PL_ProcessPendingEvents ()
   from /home/cesarb/mozilla/libxpcom.so
#15 0x400c0cb9 in nsEventQueueImpl::ProcessPendingEvents ()
   from /home/cesarb/mozilla/libxpcom.so
#16 0x404b8813 in NSGetModule ()
   from /home/cesarb/mozilla/components/libwidget_gtk.so
#17 0x404b858d in NSGetModule ()
   from /home/cesarb/mozilla/components/libwidget_gtk.so
#18 0x4065ac80 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#19 0x4065c348 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#20 0x4065c953 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#21 0x4065caec in g_main_run () from /usr/lib/libglib-1.2.so.0
#22 0x4057cbd7 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#23 0x404b8d0c in NSGetModule ()
   from /home/cesarb/mozilla/components/libwidget_gtk.so
#24 0x4046e13a in nsJSUtils::mCachedSecurityManager ()
   from /home/cesarb/mozilla/components/libnsappshell.so
#25 0x804d694 in JS_PushArguments ()
#26 0x804df25 in JS_PushArguments ()
---Type <return> to continue, or q <return> to quit---
#27 0x40252f5c in __libc_start_main () from /lib/libc.so.6

I don't think I can change to OS All, but I'll try.

Comment 3

18 years ago
Updating keywords & OS as per reporters request.
Severity: major → critical
Keywords: crash, intl
OS: Windows 98 → All
Hardware: PC → All

Comment 4

18 years ago
> Cesar Eduardo Barros
Are you using 0404 trunk build? or bidi build ?
This looks like a XPCOM problem, may not related to bidi issue. 

Comment 5

18 years ago
Marking as dupe of 74728. Changing QA contact to ylong@netscape.com.  

Yuying, please reopen in case you still see this problem while running smoke 
tests on the bidi build.

*** This bug has been marked as a duplicate of 74728 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
QA Contact: andreasb → ylong
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Not reproduce on 04-19 Bidi build.  Mark it as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.