Table Cell Contents wrapping incorrectly

VERIFIED DUPLICATE of bug 54565

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 54565
17 years ago
16 years ago

People

(Reporter: Shawn Neumann, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2001040504 (and the last while)
OS: W2K

I checked most of the wrapping bugs, however they didn't seem to apply to this
case (see URL).  It is quite obvious what is happening here, the cell is being
wrapped when it should not be.  This works correctly in NS6 and has worked in
Mozilla (I'm not sure when I noticed the problem appear).  I works as expected
in all other major browsers.

Comment 1

17 years ago
I see this as well with mozilla 040504 win32 build on win2000.  Confirming and
sending to Tables.  Will attach a testcase.
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
QA Contact: doronr → amar

Comment 2

17 years ago
So it looks like we're not respecting the fact that there is no space between
the image tags in Mozilla.  Not sure what the spec is here.

Comment 3

17 years ago
Created attachment 29870 [details]
testcase with two images no space. Mozilla breaks IE does not.
the problem is the overconstrained width (100% + width of first cell in row = 
100% cannot be satisfied).

This is a dup.. can't find the original.
Whiteboard: DUPEME
Found it!

*** This bug has been marked as a duplicate of 60562 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
 This bug was marked resolved because the dupe of this bug# 60562 was marked 
resolved... But the actual problem in this bug was not resolved... The images 
are still palced on top of each other instead of horizontally..
Reopening this bug

Updated

17 years ago
Assignee: karnaze → attinasi
Status: REOPENED → NEW

Comment 7

17 years ago
Marc, this is probably a dup of the infamous "images without whitespace break in 
a table cell" bug. Give me the original bug number, and I'll start duping 
against it. 
(Reporter)

Comment 8

17 years ago
Just a reminder... look at the test case to confirm, not the orriginal URL in
the report since that page has implemented work-arounds to avoid this problem.
(Assignee)

Comment 9

17 years ago
Bug 54565 is the one that is about contiguous images reporting their combined
maxelementwidth as the block's maxelementwidth - I'll dup this one.

*** This bug has been marked as a duplicate of 54565 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
 Works fine. The images are placed side by side even with no spaces between 
them. Verfied on 2002010703 build. Platform: WIN2K
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.