review styling, border-radius trouble

RESOLVED FIXED in 2.2

Status

P3
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Pike, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
-moz-border-radius-bottomleft without prefix is border-bottom-left-radius, that's not fixed in bug 730780 for tbpl.css.

Also, border-radius doesn't collaborate with border-collapse:collapse, so the tables where we want radii, we need to switch border-collapse off.
(Assignee)

Updated

6 years ago
Priority: -- → P3
(Assignee)

Comment 1

6 years ago
(In reply to Axel Hecht [:Pike] from comment #0)
> -moz-border-radius-bottomleft without prefix is border-bottom-left-radius,
> that's not fixed in bug 730780 for tbpl.css.
> 
I've been staring at this for a while. 
So, we now use: `border-bottom-left-radius` in tbpl.css
And that's working just fine.
What is the problem? Can you please elaborate?

> Also, border-radius doesn't collaborate with border-collapse:collapse, so
> the tables where we want radii, we need to switch border-collapse off.

Sorry. I don't understand. What is the problem? 
I admit that I don't really understand border-radius (or why you would ever want that!). So, if you want space between cells (like tbpl.css does) you use `border-collapse: separate;`. Done.

Can you please elaborate what the problem is that I can attempt to fix?
(Reporter)

Comment 2

6 years ago
See http://stackoverflow.com/questions/628301/css3s-border-radius-property-and-border-collapsecollapse-dont-mix-how-can-i or other hits on google.

You just don't get border-radius if you use border-collapse.
(Reporter)

Comment 3

6 years ago
To clarify:

https://l10n.mozilla.org/shipping/signoffs/fi/fennec14:

The background has a radius, but the border goes straight beyond that. That's the effect of border-collapse.
(Assignee)

Comment 4

6 years ago
Created attachment 635809 [details] [diff] [review]
signoff table lookin splendid

Not sure this solves the title of the bug but it certainly makes the signoff page more pleasant to look at. 

Is there more work to be done on tbpl?
Attachment #635809 - Flags: review?(l10n)
(Reporter)

Comment 5

6 years ago
Comment on attachment 635809 [details] [diff] [review]
signoff table lookin splendid

Review of attachment 635809 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. I don't think there are more offenders right now.
Attachment #635809 - Flags: review?(l10n) → review+

Comment 6

6 years ago
Commit pushed to develop at https://github.com/mozilla/elmo

https://github.com/mozilla/elmo/commit/b26d6a1f47523fe353f313ef626aeaeb69682ba1
bug748978 - nice borders with border-collapse:separate, r=Pike
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Assignee: nobody → peterbe
Target Milestone: --- → 2.2
You need to log in before you can comment on or make changes to this bug.