more "Use of uninitialized value" warnings

RESOLVED FIXED

Status

()

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

Production
x86
Mac OS X

Details

(Assignee)

Description

7 years ago
as most of these are trivial fixes, i'm going to lump them together in a single bug.

https://arecibo-phx.mozilla.org/view/2535356/
Use of uninitialized value in string eq at Bugzilla/Extension/BMO/Reports.pm line 375.

https://arecibo-phx.mozilla.org/view/2516642/
Use of uninitialized value in string eq at Bugzilla/Search.pm line 1112.

https://arecibo-phx.mozilla.org/view/2502367/
Use of uninitialized value in method lookup at Bugzilla/Search.pm line 1189.

https://arecibo-phx.mozilla.org/view/2488399/
Use of uninitialized value in concatenation (.) or string at Bugzilla/Search.pm line 1715.
(Assignee)

Comment 1

7 years ago
> https://arecibo-phx.mozilla.org/view/2516642/
> Use of uninitialized value in string eq at Bugzilla/Search.pm line 1112.

i can't reproduce this one, so i'll leave it for now.
 
> https://arecibo-phx.mozilla.org/view/2502367/
> Use of uninitialized value in method lookup at Bugzilla/Search.pm line 1189.

upstreamed to bug 749074
will commit the fix to bmo from that bug here.

> https://arecibo-phx.mozilla.org/view/2488399/
> Use of uninitialized value in concatenation (.) or string at
> Bugzilla/Search.pm line 1715.

this is another instance of bug 746029, i'll fix it properly here.
(Assignee)

Comment 2

7 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified Bugzilla/Search.pm
modified extensions/BMO/lib/Reports.pm
modified template/en/default/global/code-error.html.tmpl
Committed revision 8159.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified Bugzilla/Search.pm
modified extensions/BMO/lib/Reports.pm
modified template/en/default/global/code-error.html.tmpl
Committed revision 8141.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.