[traceback] AttributeError: 'Settings' object has no attribute 'BANNERS_HASH'

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: stephend, Assigned: rik)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
https://affiliates-dev.allizom.org/link/banner/107 throws this traceback:

Traceback (most recent call last):

  File "/data/www/affiliates-dev.allizom.org/affiliates-app/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/affiliates-dev.allizom.org/affiliates-app/vendor/src/django/django/views/decorators/cache.py", line 79, in _wrapped_view_func
    response = view_func(request, *args, **kwargs)

  File "/data/www/affiliates-dev.allizom.org/affiliates-app/apps/banners/views.py", line 67, in link
    if filename in settings.BANNERS_HASH:

  File "/data/www/affiliates-dev.allizom.org/affiliates-app/vendor/src/django/django/utils/functional.py", line 277, in __getattr__
    return getattr(self._wrapped, name)

AttributeError: 'Settings' object has no attribute 'BANNERS_HASH'
There are still quite a few of these tracebacks being sent by dev. Should we be concerned?

'HTTP_FROM': 'googlebot(at)googlebot.com',
'REQUEST_URI': '/link/banner/107'
Assignee: nobody → anthony
(Assignee)

Comment 2

7 years ago
This error was caused by BANNERS_HASH being set in the local settings. And we forgot to update dev with this setting. But since, BANNERS_HASH is in the base settings.


I have no traceback with this error after June 9.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I'm happy to bump this to QA verified - I haven't seen tracebacks since dev's settings were updated.
Status: RESOLVED → VERIFIED
Product: Websites → Firefox Affiliates
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.