Attempting to install any web app from the Labs app dir throws [Object DOMError]

RESOLVED DUPLICATE of bug 747921

Status

RESOLVED DUPLICATE of bug 747921
7 years ago
3 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Details

(Reporter)

Description

7 years ago
STR:
1. Go to the Labs app directory.
2. Select the Manifest checker app.
3. Click Install once the doorhanger appears.

Result: Immediately an error message comes up saying 2[Object DOMError]", no further information is given.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120425 Firefox/15.0a1
Running inside a VMware virtual machine which is configured for seamless integration with OS X.
(Reporter)

Comment 1

7 years ago
Additional info: Other web app installation attempts from the same site produce the same error.
Marco: could you clear up the Error Console before installation and then look at it afterwards? There's usually more info there
(Reporter)

Comment 3

7 years ago
Timestamp: 4/26/2012 4:39:57 PM
Error: Error installing app: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWindowsRegKey.open]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/WebappsInstaller.jsm :: <TOP_LEVEL> :: line 224"  data: no]
Source File: resource:///modules/WebappsInstaller.jsm
Line: 36
Thanks Marco, this is bug 747921, which I just landed a fix in mozilla-central
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747921

Updated

7 years ago
No longer blocks: 731054
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.