Last Comment Bug 749127 - Intermittent browser/devtools/debugger/test/browser_dbg_propertyview-06.js | The localScope doesn't contain all the created variable elements. - Got 6, expected 7
: Intermittent browser/devtools/debugger/test/browser_dbg_propertyview-06.js | ...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: x86 Windows 7
: -- normal (vote)
: Firefox 15
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-04-26 03:28 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.84 KB, patch)
2012-04-26 04:13 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v1.1 (1.83 KB, patch)
2012-04-26 04:36 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-04-26 03:28:48 PDT
Rev3 WINNT 6.1 fx-team pgo test mochitest-other on 2012-04-25 18:49:42 PDT for push c7523bf07e12
slave: talos-r3-w7-046

https://tbpl.mozilla.org/?tree=Fx-Team&rev=c7523bf07e12
https://tbpl.mozilla.org/php/getParsedLog.php?id=11213326&tree=Fx-Team

{
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-05.js | Console message: [JavaScript Error: "gDebuggee.simpleCall is not a function" {file: "chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-05.js" line: 90}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-05.js | Test timed out
args: ['c:\\talos-slave\\test\\build\\bin\\screenshot.exe', 'c:\\users\\cltbld\\appdata\\local\\temp\\mozilla-test-fail_2o6ife']
SCREENSHOT: <snip>
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-05.js | finished in 30055ms
...
...
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-06.js | The localScope doesn't contain all the created variable elements. - Got 6, expected 7
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 418
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-06.js :: <TOP_LEVEL> :: line 86
}
Comment 1 Victor Porof [:vporof][:vp] 2012-04-26 04:13:22 PDT
Created attachment 618614 [details] [diff] [review]
v1

Derp.
We get the additional "this" variable in the local scope. This test doesn't and shouldn't handle that.
Comment 2 Victor Porof [:vporof][:vp] 2012-04-26 04:19:52 PDT
Note: the failure in propertyview-05 is unrelated to the one in propertyview-06 (fixed by the attached patch), but the reason is identical to the other timeout debugger test failures ("gDebuggee.simpleCall is not a function" and "this._model is null in source-editor-orion.jsm").
Comment 3 Ed Morley [:emorley] 2012-04-26 04:24:31 PDT
Thanks for fixing this so quickly :-)

And yeah missed the 05/06, read them both as the same. I'll morph this to be about 06.
Comment 4 Victor Porof [:vporof][:vp] 2012-04-26 04:36:57 PDT
Created attachment 618625 [details] [diff] [review]
v1.1

Updated commit message.
Comment 5 Mihai Sucan [:msucan] 2012-04-26 05:39:17 PDT
(In reply to Victor Porof from comment #2)
> Note: the failure in propertyview-05 is unrelated to the one in
> propertyview-06 (fixed by the attached patch), but the reason is identical
> to the other timeout debugger test failures ("gDebuggee.simpleCall is not a
> function" and "this._model is null in source-editor-orion.jsm").

This seems like a case where the editor API is used before it is initialized.
Comment 6 Victor Porof [:vporof][:vp] 2012-04-26 05:41:36 PDT
(In reply to Mihai Sucan [:msucan] from comment #5)
> (In reply to Victor Porof from comment #2)
> 
> This seems like a case where the editor API is used before it is initialized.

Yup, just as we discussed on IRC. The originating problem for the propertyview-05 failure is the same as everywhere else.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-05-07 10:17:39 PDT
https://hg.mozilla.org/integration/fx-team/rev/0e296599e861
Comment 8 Tim Taubert [:ttaubert] 2012-05-07 23:56:13 PDT
https://hg.mozilla.org/mozilla-central/rev/0e296599e861

Note You need to log in before you can comment on or make changes to this bug.