[traceback] IntegrityError: (1062, 'Duplicate entry \'\xed\xbc"u\x07\xb2\' for key \'private_key\'')

VERIFIED FIXED in 6.5.2

Status

addons.mozilla.org Graveyard
Developer Pages
P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Victor Carciu, Assigned: kumar)

Tracking

({regression})

unspecified
6.5.2
x86_64
Windows 7
regression

Details

(URL)

(Reporter)

Description

6 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120418 Firefox/14.0a1

Steps to reproduce:
1.Login to https://marketplace-dev.allizom.org/en-US/developers/submissions
2.Open one app with "Manage in-app payments" option available.
3.Select "Manage in-app payments" , fill the Postback URL and Chargeback URL and click Save Changes

Expected results:
In app payments changes are successfully saved and Application Key and Application Secret are generated.

Actual results:
Ooops error is displayed after pressing Save Changes button.

Notes:
Not reproducible in production
Reproduced using win7 OS.
(Reporter)

Comment 1

6 years ago
Please view screencast for this issue: http://screencast.com/t/OqUPa9n5

Comment 2

6 years ago
Traceback (most recent call last):

  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 112, in wrapper
    return f(*args, **kw)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 104, in wrapper
    return f(*args, **kw)

  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django-waffle/waffle/decorators.py", line 36, in _wrapped_view
    return view(request, *args, **kwargs)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/addons/decorators.py", line 29, in wrapper
    return f(request, addon, *args, **kw)

  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/decorators.py", line 42, in wrapper
    return fun()

  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/decorators.py", line 27, in <lambda>
    *args, **kw)

  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/db/transaction.py", line 211, in inner
    return func(*args, **kwargs)

  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/views.py", line 441, in in_app_config
    new_inapp.set_private_key(InappConfig.generate_private_key())

  File "/data/www/addons-dev.allizom.org/zamboni/mkt/inapp_pay/models.py", line 70, in set_private_key
    [raw_value, _get_key()])

  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/django/django/db/backends/mysql/base.py", line 86, in execute
    return self.cursor.execute(query, args)

  File "/usr/lib64/python2.6/site-packages/MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)

  File "/usr/lib64/python2.6/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue

IntegrityError: (1062, 'Duplicate entry \'\xed\xbc"u\x07\xb2\' for key \'private_key\'')

Updated

6 years ago
Summary: [Marketplace]Ooops error when trying to set-up in app payments. → [traceback] IntegrityError: (1062, 'Duplicate entry \'\xed\xbc"u\x07\xb2\' for key \'private_key\'')
Assignee: nobody → kumar.mcmillan
Priority: -- → P1
Target Milestone: --- → 6.5.2
Weird. It looks like MySQL has issues with trailing spaces when processing varbinary internally (there are a couple open bugs). I switched the column to a BLOB and that solved the dupe checking.

https://github.com/mozilla/zamboni/commit/7803c73
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 4

6 years ago
this is fixed now. Thanks for catching this bug!
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.