Mutex api methods lock,unlock,tryLock should return uint showing the lock count

VERIFIED WONTFIX

Status

Tamarin
Workers
VERIFIED WONTFIX
6 years ago
6 years ago

People

(Reporter: Dan Schaffer, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

6 years ago
The Mutex api does not match the Workers spec.  The Mutex class methods should return the lock count.

import flash.concurrent.Mutex;
var m:Mutex=new Mutex();
print(m.lock()); // actual: undefined, expected: 1
print(m.unlock()); // actual: undefined, expected: 0
print(m.tryLock()); // actual: true, expected: 1
(Reporter)

Updated

6 years ago
Blocks: 695061
(Reporter)

Comment 1

6 years ago
spec was updated. not a bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.