There is currently no way to for extensions to enumerate manifest locations.

RESOLVED DUPLICATE of bug 890545

Status

()

Core
XPCOM
--
major
RESOLVED DUPLICATE of bug 890545
6 years ago
4 years ago

People

(Reporter: Alex, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
There is no access api for sModuleLocations.
sModuleLocations has no api to give access to the locations of Manifests registered with XRE_AddManifestLocation.  As a result, extensions are unable to enumerate the locations of registered manifests.  This is a core component that extensions such Chrome List rely on.  I believe this functionality was previous provided by ChromeML in nsChromeRegistry.cpp.

-- See also --
https://bugzilla.mozilla.org/show_bug.cgi?id=611430
https://mxr.mozilla.org/mozilla-central/source/xpcom/components/nsComponentManager.cpp#325
(Reporter)

Updated

6 years ago
See Also: → bug 611430
(Reporter)

Updated

6 years ago
(Reporter)

Updated

5 years ago
Keywords: regression
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890545
You need to log in before you can comment on or make changes to this bug.