From autocomplete popups reopens after tapping on autocomplete entry

REOPENED
Unassigned

Status

()

REOPENED
7 years ago
2 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({regression, testcase})

Trunk
ARM
Android
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 618678 [details]
testcase

I suspect this is a regression from bug 736008, I don't see this bug occuring in Aurora, at least (yet).

Steps to reproduce:
- Go to testcase
- Type 'a', then submit
- Type 'ab', then submit
- Type 'abc', then submit
- Tap on the text input to open the form autocomplete popup
- Tap on the 'a' entry in there


Expected result:
- 'a' appears in the text input, form autocomplete popup disappears

Actual result:
- 'a' appears in the text input, form autocomplete popup reopens with remaining suggestions

Comment 1

7 years ago
This sounds more like it would be caused by bug 735747, but that's in aurora. Maybe it's some bad interaction between that bug and bug 736008.
(Reporter)

Comment 2

7 years ago
Yeah,  I guess you're right, I saw this bug too in a trunk build before bug 736008 was fixed.

Updated

7 years ago
Blocks: 735747

Comment 3

6 years ago
As a regression window : 
Good build:17.04.2012
Bad build:18.04.2012

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c61e7c3a232a&tochange=0c7e2911be75
Right, bug 735747.
(Reporter)

Comment 5

6 years ago
In Firefox desktop, there is a mSuppressOnInput that is set to false to prevent the autocomplete from appearing oninut, in nsFormFillController.cpp.
So I guess this needs something similar.

Something like this?
+  this._suppresinput = true;
editableElement.setUserInput(aData);
+  this._suppresinput = false;

And then in http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#4638
+ if (this._suppresinput)
+  break;
(Reporter)

Comment 6

6 years ago
Created attachment 731450 [details] [diff] [review]
patch

Something like this.
I tried my own build, but somehow that build seems hosed. Or isn't it possible to build on MacOS X platorm, realibly?
(Reporter)

Comment 8

6 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #6)
> I tried my own build, but somehow that build seems hosed. Or isn't it
> possible to build on MacOS X platorm, realibly?

Ugh, this happened because the patch is not good.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.