Last Comment Bug 749231 - toolkit/devtools/debugger xpcshell tests should always run with devtools.debugger.log pref set
: toolkit/devtools/debugger xpcshell tests should always run with devtools.debu...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Jim Blandy :jimb
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 09:16 PDT by Jim Blandy :jimb
Modified: 2012-05-02 13:14 PDT (History)
2 users (show)
jimb: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Set the devtools.debugger.log pref in head_dbg.js, so we always get packet logs. (878 bytes, patch)
2012-04-26 09:16 PDT, Jim Blandy :jimb
past: review+
Details | Diff | Splinter Review

Description Jim Blandy :jimb 2012-04-26 09:16:05 PDT
Created attachment 618683 [details] [diff] [review]
Set the devtools.debugger.log pref in head_dbg.js, so we always get packet logs.

The devtools.debugger.log pref enables various kinds of logging within the debugger, including logging the packets exchanged between client and server. This is really useful to see when a test has failed, and since runxpcshelltests.py doesn't show the output anyway unless the test does fail, head_dbg.js should simply set that pref unconditionally.
Comment 1 Jim Blandy :jimb 2012-04-26 09:19:46 PDT
Try: https://tbpl.mozilla.org/?tree=Try&rev=c8274a4f81bb
Comment 3 Tim Taubert [:ttaubert] 2012-05-02 06:47:24 PDT
https://hg.mozilla.org/mozilla-central/rev/fee74fe8354c
Comment 4 :Ehsan Akhgari 2012-05-02 12:43:38 PDT
Backed out the latest fx-team merge whole-sale because of Ts regressions:

https://hg.mozilla.org/mozilla-central/rev/b0200dab0ccc

Please reland only after investigating and fixing the regression.  Thanks!
Comment 5 :Ehsan Akhgari 2012-05-02 13:14:34 PDT
I messed up and backed out the wrong range, sorry about that.  I backed out my backout, so this is still on mozilla-central:

https://hg.mozilla.org/mozilla-central/rev/dec5b367c421

Note You need to log in before you can comment on or make changes to this bug.