Closed Bug 749255 Opened 11 years ago Closed 11 years ago

Message filters not clearing new mail flag

Categories

(Thunderbird :: General, defect)

12 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 749282

People

(Reporter: matte, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Downloaded new messages off of the server, my message filters automatically ran and sorted the messages in to the proper folders (including junk and trash)


Actual results:

Messages were sorted properly and the new message icon appeared in the task bar with the notice "Local Folders has 1 new message".  Local Folders also turned blue as if it had an unread message.  None of the folders actually had an unread new message for me to read.


Expected results:

All of the messages were marked as read so there should not have been any new message notifications.  This is how it worked prior to 12.0.
Looks similar to bug 749282 which in turn relates to bug 748997. Are you using a POP account, and if yes, is it set to leave messages on the server?

Tools > Account Settings > /account/ > Server Settings
Yes, this is a POP account and yes I have it set to leave messages on the server.  Sorry for the duplicate issue.
I'm duping this against bug 749282 for now since this looks like a better match, with the only difference being manual vs. filter-initiated message handling.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749282
You need to log in before you can comment on or make changes to this bug.