Closed Bug 749256 Opened 10 years ago Closed 10 years ago

crash in SessionStorageTraverser

Categories

(Core :: DOM: Core & HTML, defect)

15 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 749182
Tracking Status
firefox15 - ---

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash)

Crash Data

It first appeared in 15.0a1/20120426 and is #4 top crasher over the last day.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=75c7378c87b6&tochange=cc5254f9825f
It's probably related to bug 749182.

Signature 	ChildFinder::NoteXPCOMChild(nsISupports*) More Reports Search
UUID	bc00e757-5e43-4097-9396-f657c2120426
Date Processed	2012-04-26 17:10:34
Uptime	1194
Last Crash	26.4 minutes before submission
Install Age	1.2 hours since version was first installed.
Install Time	2012-04-26 15:56:28
Product	Firefox
Version	15.0a1
Build ID	20120426030504
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x70747468
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0046, AdapterSubsysID: 12d21043, AdapterDriverVersion: 8.15.10.2361
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3863621632
System Memory Use Percentage	36
Available Page File	5939916800
Available Physical Memory	2573955072

Frame 	Module 	Signature 	Source
0 	xul.dll 	ChildFinder::NoteXPCOMChild 	xpcom/base/nsCycleCollector.cpp:2050
1 	xul.dll 	SessionStorageTraverser 	dom/src/storage/nsDOMStorage.cpp:707
2 	xul.dll 	nsTHashtable<nsPtrHashKey<nsIContent> >::s_EnumStub 	obj-firefox/dist/include/nsTHashtable.h:500
3 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.cpp:750
4 	xul.dll 	nsTHashtable<nsPtrHashKey<nsObjectFrame> >::EnumerateEntries 	obj-firefox/dist/include/nsTHashtable.h:251
5 	xul.dll 	DOMStorageImpl::cycleCollection::Traverse 	dom/src/storage/nsDOMStorage.cpp:717
6 	xul.dll 	nsPurpleBuffer::RemoveSkippable 	xpcom/base/nsCycleCollector.cpp:2125
7 	xul.dll 	nsCycleCollector::ForgetSkippable 	xpcom/base/nsCycleCollector.cpp:2149
8 	xul.dll 	nsCycleCollector_forgetSkippable 	xpcom/base/nsCycleCollector.cpp:3570
9 	xul.dll 	TimerFireForgetSkippable 	dom/base/nsJSEnvironment.cpp:3099
10 	xul.dll 	CCTimerFired 	dom/base/nsJSEnvironment.cpp:3145
11 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:508
12 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:591
13 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
14 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
15 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
16 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
17 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
18 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:267
19 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
20 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3780
21 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3857
22 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3933
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=ChildFinder%3A%3ANoteXPCOMChild%28nsISupports*%29
Crash Signature: [@ ChildFinder::NoteXPCOMChild(nsISupports*)] → [@ ChildFinder::NoteXPCOMChild(nsISupports*)] [@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) | PL_DHashTableOperate | xul.dll@0x75051f | SessionStorageTraverser(nsSessionStorageEntry* void*)] [@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) | xul.dll@0x…
Summary: crash in SessionStorageTraverser @ ChildFinder::NoteXPCOMChild → crash in SessionStorageTraverser
Crash Signature: void*)] [@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) | SearchTable] → void*)] [@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) | SearchTable] [@ GCGraphBuilder::NoteXPCOMChild | SessionStorageTraverser ]
It only happened in 15.0a1/20120426. It's fixed by bug 749182.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749182
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.