Fonts look fuzzy and blurry until hovered. (persisting since 14 branch)

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Rakshith, Unassigned)

Tracking

15 Branch
x86
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 618720 [details]
the circled text outline (colored, zoom into the image to notice.) is the result of hovering on it. the rest is blurry because they aren't colored.

The words of the line where the mouse icon is placed (has to be on any word of the line) turn sharp. The rest words on the page remain fuzzy. The line which got sharp after mouse was hovered on, retains fuzziness after sometime as it is unhovered by the mouse. However it can vary too to what length the amount of words that sharpens due to hovering over effect is, and also not everywhere do I see this problem. This blurriness in font is noticeable on Facebook and "about:config" in Firefox and text input fields (Bugzilla included) to my knowledge. I suspect the size of the text and my custom gfx configs have something to do with it.

Here is my about:support clipboard copy.





  Application Basics

        Name
        Firefox

        Version
        15.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.2; rv:15.0) Gecko/20120426 Firefox/15.0a1

        Profile Folder

          Show Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.0.4b.3445
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Element Hiding Helper for Adblock Plus
        1.2.3a.417
        false
        elemhidehelper@adblockplus.org

        PDF Viewer
        0.2.536
        false
        uriloader@pdf.js

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.check_doc_frequency
        1

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        706560

        browser.places.smartBookmarksVersion
        4

        browser.search.useDBForOrder
        true

        browser.sessionstore.restore_pinned_tabs_on_demand
        true

        browser.startup.homepage
        about:home

        browser.startup.homepage_override.buildID
        20120426040218

        browser.startup.homepage_override.mstone
        15.0a1

        browser.tabs.addEllipsisToCropped
        true

        dom.ipc.plugins.java.enabled
        true

        dom.vibrator.enabled
        false

        extensions.lastAppVersion
        15.0a1

        gfx.color_management.enablev4
        true

        gfx.direct2d.force-enabled
        true

        gfx.downloadable_fonts.fallback_delay
        2000

        gfx.filter.nearest.force-enabled
        true

        gfx.font_rendering.cleartype.always_use_for_content
        true

        gfx.font_rendering.directwrite.enabled
        true

        gfx.font_rendering.fallback.always_use_cmaps
        true

        gfx.font_rendering.graphite.enabled
        true

        gfx.use_text_smoothing_setting
        true

        javascript.options.mem.gc_incremental
        true

        layers.acceleration.force-enabled
        true

        layers.offmainthreadcomposition.enabled
        true

        media.autoplay.enabled
        false

        network.cookie.prefsMigrated
        true

        network.http.pipelining
        true

        network.http.pipelining.aggressive
        true

        network.http.pipelining.ssl
        true

        network.http.proxy.pipelining
        true

        places.database.lastMaintenance
        1335375182

        places.history.expiration.transient_current_max_pages
        53435

        places.history.expiration.transient_optimal_database_size
        85495480

        plugin.allow.asyncdrawing
        true

        plugins.click_to_play
        true

        privacy.cpd.cookies
        false

        privacy.cpd.sessions
        false

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        security.OCSP.disable_button.managecrl
        false

        security.disable_button.openCertManager
        false

        security.disable_button.openDeviceManager
        false

        security.warn_viewing_mixed
        false

        webgl.force-enabled
        true

        webgl.msaa-force
        true

  Graphics

        Adapter Description
        Mobile Intel(R) 965 Express Chipset Family (Microsoft Corporation - WDDM 1.1)

        Vendor ID
        0x8086

        Device ID
        0x2a02

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd32 igd10umd32

        Driver Version
        8.15.10.2548

        Driver Date
        10-4-2011

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.2.8250.0)

        ClearType Parameters
        DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400 ] DISPLAY4 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400 ]

        WebGL Renderer
        Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family (Microsoft Corporation - WDDM 1.1)) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9
        4.9

        NSS
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS Util
        3.13.4.0
        3.13.4.0

        NSS SSL
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS S/MIME
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Possibly related or dupe of bug 793280.
Rakshith, is this still a problem in Fx16 beta 6?
(Reporter)

Comment 3

5 years ago
No.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.