Last Comment Bug 749313 - Wiki: Edit screen should provide tag suggestions
: Wiki: Edit screen should provide tag suggestions
Status: RESOLVED FIXED
[mentor=sheppy]
:
Product: Mozilla Developer Network
Classification: Other
Component: Editing (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Walsh :davidwalsh
:
:
Mentors:
: 772425 (view as bug list)
Depends on:
Blocks: 727277
  Show dependency treegraph
 
Reported: 2012-04-26 12:35 PDT by David Walsh :davidwalsh
Modified: 2013-11-11 18:21 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David Walsh :davidwalsh 2012-04-26 12:35:13 PDT
Tag editing now uses jQuery UI's tagit and everything is working great.  It would be nice, however, to autosuggest popular tags, much as the profile editing screen does.

All that needs to happen is a variable called "INTEREST_SUGGESTIONS" must be output to the page as an array of string tags.  This same functionality can be found on the profile_edit.html
Comment 1 Les Orchard [:lorchard] 2012-04-26 12:39:45 PDT
FWIW: I don't think we should populate a static list here. There are a lot of tags and they apply popularly in different clusters to different parts of the site. Instead, we should have a tag suggestion backend that can search by partial match to supply tag-it with data
Comment 2 Les Orchard [:lorchard] 2012-05-03 08:24:52 PDT
Some possible leads for suggestion code that supports taggit:

https://bitbucket.org/fabian/django-taggit-autosuggest
https://github.com/frankwiles/django-taggit-suggest
Comment 3 David Walsh :davidwalsh 2012-07-10 07:10:30 PDT
*** Bug 772425 has been marked as a duplicate of this bug. ***
Comment 4 David Walsh :davidwalsh 2012-07-10 07:25:22 PDT
For the sake of launch, :sheppy, if you can give me a reasonable list of frequently used tags ("CSS", "JavaScript", "HTML5", etc), I may be able to get that list in.

An intelligent suggestion system isn't doable by launch.
Comment 5 Eric Shepherd [:sheppy] 2013-03-26 09:29:06 PDT
*** Bug 809512 has been marked as a duplicate of this bug. ***
Comment 6 David Walsh :davidwalsh 2013-04-08 10:35:59 PDT
*** Bug 859405 has been marked as a duplicate of this bug. ***
Comment 7 David Walsh :davidwalsh 2013-04-16 14:57:46 PDT
My comment 4 still stands...
Comment 8 John Karahalis [:openjck] 2013-04-30 08:03:29 PDT
Sheppy: See comment 4.
Comment 9 Eric Shepherd [:sheppy] 2013-05-01 11:42:45 PDT
(In reply to David Walsh :davidwalsh from comment #4)
> For the sake of launch, :sheppy, if you can give me a reasonable list of
> frequently used tags ("CSS", "JavaScript", "HTML5", etc), I may be able to
> get that list in.
> 
> An intelligent suggestion system isn't doable by launch.

Can we make the list configurable in the admin panel, so we can add more later? That would be ideal. In the meantime, I'll come up with an initial list.
Comment 10 Eric Shepherd [:sheppy] 2013-05-01 12:12:46 PDT
OK, here's a page about tags, with a list to get us started:

https://developer.mozilla.org/en-US/docs/Project:MDN/Contributing/Standard_tags
Comment 11 [github robot] 2013-07-09 13:16:11 PDT
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/443e0a6d2350cc73b9790122e36df24f4830b5f2
fix bug 749313 - Provide static tag suggestions for all modes

https://github.com/mozilla/kuma/commit/4b144d39854c4095323e104dde459a8bad1affcc
Merge pull request #1212 from darkwing/tag-suggestions

fix bug 749313 - Provide static tag suggestions for all modes

Note You need to log in before you can comment on or make changes to this bug.