Going back through multiple history entries will reload pages

RESOLVED DUPLICATE of bug 1335148

Status

()

defect
RESOLVED DUPLICATE of bug 1335148
7 years ago
3 years ago

People

(Reporter: bnicholson, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

STR:
1) Go to http://www.google.com
2) Go to http://people.mozilla.com/~bnicholson/test/page1.html
3) Go to http://people.mozilla.com/~bnicholson/test/page2.html
4) Click back
5) Click back

Expected result:
Google will load instantly (and with no throbber)

Actual result:
The throbber is shown, and the page is not pulled from the cache.

If you click back after step 2, Google will load instantly, so it appears that this bug only happens when going back more than once. This issue is not reproducible on desktop.
This is happening because we limit the cache size:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/app/mobile.js#143

This pref value is different on desktop because they have more resources to work with. I think it is a WONTFIX.
blocking-fennec1.0: ? → -
I think we do want to make the change. Maybe bump to 5, but not a blocker.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335148
You need to log in before you can comment on or make changes to this bug.