Leaving PB mode and cancelling active download does not delete .part file

RESOLVED DUPLICATE of bug 509190

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 509190
6 years ago
6 years ago

People

(Reporter: Christian Ascheberg, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Open Firefox, start private browsing mode
2. Start downloading a (large) file
3. Leave PB mode (switch to non-PM mode / quit Firefox) while download is active
4. Warning message will be shown, select "Cancel 1 Download"

Result:
download-filename file is removed, but associated
.part file of the download will not be removed

Expected:
both files should be removed

Comment 1

6 years ago
Marco, do you know where these files are created?

Comment 3

6 years ago
Hmm, we probably should figure out where the caller is, and how we can modify it to propagate the PB status in to the external app helper service.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

6 years ago
bug 509190?

Comment 5

6 years ago
Yeah, this seems like a dupe!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509190
You need to log in before you can comment on or make changes to this bug.