Last Comment Bug 749429 - Increase displayport to 2000 for all strategies
: Increase displayport to 2000 for all strategies
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 15:54 PDT by JP Rosevear [:jpr]
Modified: 2012-04-29 15:43 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
beta+


Attachments
Patch (2.78 KB, patch)
2012-04-27 14:13 PDT, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
jpr: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description JP Rosevear [:jpr] 2012-04-26 15:54:01 PDT
Increase displayport to 2000 for all strategies (or maybe just velocity and prediction bias).
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-27 14:13:16 PDT
Created attachment 619177 [details] [diff] [review]
Patch
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-27 14:14:01 PDT
(In reply to JP Rosevear [:jpr] from comment #0)
> Increase displayport to 2000 for all strategies (or maybe just velocity and
> prediction bias).

Prediction bias (when not moving) is already at 3000.
Comment 3 Chris Lord [:cwiiis] 2012-04-27 15:28:44 PDT
Comment on attachment 619177 [details] [diff] [review]
Patch

Review of attachment 619177 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me.
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-27 22:03:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb240b2a69db
Comment 5 JP Rosevear [:jpr] 2012-04-28 05:38:37 PDT
Comment on attachment 619177 [details] [diff] [review]
Patch

Mobile only
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-28 14:41:18 PDT
Improvement! Robocop Checkerboarding Benchmark decrease 26.8% on Android 2.2 (Native) Mozilla-Inbound
-------------------------------------------------------------------------------------------
    Previous: avg 8830.306 stddev 642.856 of 30 runs up to revision 1d3c3f280f60
    New     : avg 6465.964 stddev 431.760 of 5 runs since revision cb240b2a69db
    Change  : -2364.342 (26.8% / z=3.678)
    Graph   : http://mzl.la/JQh3fM
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-29 07:12:46 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/620975d07853
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2012-04-29 11:06:12 PDT
(In reply to Mark Finkle (:mfinkle) from comment #7)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/620975d07853

We wanted to bake this on m-c for a bit to make sure it didn't introduce extra jank.
Comment 9 JP Rosevear [:jpr] 2012-04-29 15:15:50 PDT
(In reply to Kartikaya Gupta (:kats) from comment #8)
> (In reply to Mark Finkle (:mfinkle) from comment #7)
> > https://hg.mozilla.org/releases/mozilla-aurora/rev/620975d07853
> 
> We wanted to bake this on m-c for a bit to make sure it didn't introduce
> extra jank.

I think we just go for it, it makes checkboarding a lot better, if its too janky, we can revisit.
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-04-29 15:43:05 PDT
http://hg.mozilla.org/mozilla-central/rev/cb240b2a69db

Note You need to log in before you can comment on or make changes to this bug.