Closed Bug 74944 Opened 24 years ago Closed 24 years ago

crash on quit in nsOutliner*

Categories

(Core :: XUL, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9

People

(Reporter: bugzilla, Assigned: sspitzer)

References

Details

(Keywords: crash, regression)

Attachments

(1 file)

i'm not sure what the appropriate component would be for this, so trying xp
toolkit since the traces begin with nsOutliner. pls do reassign as needed, thx!

found using 2001.04.04.14 linux comm opt bits. in all cases, iirc, i had both a
mailnews and browser window open when i had i had quit the app. sorry about the
vagueness --i thought these were just one-time crashes, but decided to file this
when i happened three times with the same build...

has anyone else seen this, either on another platform or using the preview
theme?

the first crash occurred during a session in which i had installed/switched on
the modern-mojo preview theme. Talkback incident ID 28685567:

nsOutlinerSelection::ClearSelection() 
nsMsgDBView::OnAnnouncerGoingAway() 
nsMsgDatabase::NotifyAnnouncerGoingAway() 
nsMsgDatabase::ForceClosed() 
nsMsgDatabase::CleanupCache() 
nsMsgDBModule::Shutdown() 
nsMsgDBModule::~nsMsgDBModule() 
nsMsgDBModule::Release() 
nsDll::Shutdown() 
nsFreeLibrary() 
nsFreeLibraryEnum() 
_hashEnumerate__FP11PLHashEntryiPv() 
libplds4.so + 0x1410 (0x40184410) 
nsHashtable::Enumerate() 
nsNativeComponentLoader::UnloadAll() 
nsComponentManagerImpl::UnloadLibraries() 
nsComponentManagerImpl::Shutdown() 
NS_ShutdownXPCOM() 
main() 
libc.so.6 + 0x189cb (0x402489cb)


the second crash occurred in a later session, still using modern-mojo. talkback
incident 28685828:

nsOutlinerBodyFrame::GetOutlinerBody() 
nsOutlinerSelection::FireOnSelectHandler() 
nsOutlinerSelection::ClearSelection() 
nsMsgDBView::OnAnnouncerGoingAway() 
nsMsgDatabase::NotifyAnnouncerGoingAway() 
nsMsgDatabase::ForceClosed() 
nsMsgDatabase::CleanupCache() 
nsMsgDBModule::Shutdown() 
nsMsgDBModule::~nsMsgDBModule() 
nsMsgDBModule::Release() 
nsDll::Shutdown() 
nsFreeLibrary() 
nsFreeLibraryEnum() 
_hashEnumerate__FP11PLHashEntryiPv() 
libplds4.so + 0x1410 (0x40184410) 
nsHashtable::Enumerate() 
nsNativeComponentLoader::UnloadAll() 
nsComponentManagerImpl::UnloadLibraries() 
nsComponentManagerImpl::Shutdown() 
NS_ShutdownXPCOM() 
main() 
libc.so.6 + 0x189cb (0x402489cb)


the third crash occurred today --i had switched back to the classic theme
[several sessions earlier], however. talkback incident 28723034:

0x00000005 
nsOutlinerBodyFrame::InvalidateRow() 
nsOutlinerBodyFrame::InvalidateRange() 
nsOutlinerSelection::ClearSelection() 
nsMsgDBView::OnAnnouncerGoingAway() 
nsMsgDatabase::NotifyAnnouncerGoingAway() 
nsMsgDatabase::ForceClosed() 
nsMsgDatabase::CleanupCache() 
nsMsgDBModule::Shutdown() 
nsMsgDBModule::~nsMsgDBModule() 
nsMsgDBModule::Release() 
nsDll::Shutdown() 
nsFreeLibrary() 
nsFreeLibraryEnum() 
_hashEnumerate__FP11PLHashEntryiPv() 
libplds4.so + 0x1410 (0x40184410) 
nsHashtable::Enumerate() 
nsNativeComponentLoader::UnloadAll() 
nsComponentManagerImpl::UnloadLibraries() 
nsComponentManagerImpl::Shutdown() 
NS_ShutdownXPCOM() 
main() 
libc.so.6 + 0x189cb (0x402489cb)
Summary: crash on quit in nsOutliner → crash on quit in nsOutliner*
Adding Hyatt for outliner connection.  We've never given crash on exit bugs
dogfood status so minus on that.
Keywords: nsdogfoodnsdogfood-
The following calls appears in all of the above stack-traces, so they are
probably the problem:

nsOutlinerSelection::ClearSelection() 
nsMsgDBView::OnAnnouncerGoingAway()


I'm investigating...
No one has touched ClearSelection() or OnAnnoucnerGoingAway() for quite a
while... The last one to touch nsOutlinerSelection.cpp was Seth, with his
AdjustSelection() checkin.

Can this possibly be related? I doubt it.

I don't crash, and I don't see anything wrong in the code.
->hyatt
Assignee: trudelle → hyatt
yes, I get this too.

here's my stace trace:

nsOutlinerSelection::FireOnSelectHandler() line 660 + 36 bytes
nsOutlinerSelection::ClearSelection(nsOutlinerSelection * const 0x06c60210) line 
441
nsMsgDBView::OnAnnouncerGoingAway(nsMsgDBView * const 0x0806db44, 
nsIDBChangeAnnouncer * 0x06c32f00) line 3279
nsMsgDatabase::NotifyAnnouncerGoingAway(nsMsgDatabase * const 0x06c32f00) line 
473 + 16 bytes
nsMsgDatabase::ForceClosed(nsMsgDatabase * const 0x06c32f00) line 968
nsMsgDatabase::CleanupCache() line 511
nsMsgDBModule::Shutdown() line 102
nsMsgDBModule::~nsMsgDBModule() line 83
nsMsgDBModule::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsMsgDBModule::Release(nsMsgDBModule * const 0x06659f90) line 85 + 151 bytes
nsDll::Shutdown() line 468 + 18 bytes
nsFreeLibrary(nsDll * 0x00a41190, nsIServiceManager * 0x00000000, int 3) line 
379
nsFreeLibraryEnum(nsHashKey * 0x00a42ef0, void * 0x00a41190, void * 0x0012fdf0) 
line 427 + 64 bytes
_hashEnumerate(PLHashEntry * 0x00a42eb0, int 47, void * 0x0012fdd4) line 193 + 
26 bytes
PL_HashTableEnumerateEntries(PLHashTable * 0x00a37108, int (PLHashEntry *, int, 
void *)* 0x10026990 _hashEnumerate(PLHashEntry *, int, void *), void * 
0x0012fdd4) line 413 + 15 bytes
nsHashtable::Enumerate(int (nsHashKey *, void *, void *)* 0x10066470 
nsFreeLibraryEnum(nsHashKey *, void *, void *), void * 0x0012fdf0) line 359 + 21 
bytes
nsNativeComponentLoader::UnloadAll(nsNativeComponentLoader * const 0x00a37d80, 
int 3) line 1000
nsComponentManagerImpl::UnloadLibraries(nsIServiceManager * 0x00000000, int 3) 
line 1877 + 22 bytes
nsComponentManagerImpl::Shutdown() line 358
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 491 + 11 bytes
main(int 2, char * * 0x00a34120) line 1324 + 8 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()

I think this is my fault, not hyatt's.

here's what's going on:

when we quick, the db gets closed and the view gets notified, just like it would 
if you did "compact folder" and the db got closed.

perhaps the layout dll is already unloaded and that is why we crash.  I'm not 
sure.

one thing we could do is on shutdown, bail out of 
nsMsgDBView::OnAnnouncerGoingAway() early.  there is no need to poke the 
outliner or the selection, since we don't care, since we are shutting down.

hyatt, you want to give this bad boy to me?
go for it.

Assignee: hyatt → sspitzer
i see this on mac [2001.04.09.10, comm bits]. all i need to do is to have opened
mail during the session.
OS: Linux → All
Hardware: PC → All
P1
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9
*** Bug 74849 has been marked as a duplicate of this bug. ***
testing a potential fix.

the fix is to close the dbview on the unload handler for our messenger xul.

that should do the trick
fixed.

poor hyatt.  he get's blamed for all my outliner badness.
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
*** Bug 75342 has been marked as a duplicate of this bug. ***
haven't seen this for some time... vrfy fixed with 2001.04.25.0x bits on the
three main platforms.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: