nspr does not build with Tru64 4.0F

VERIFIED FIXED in mozilla0.9

Status

defect
P2
normal
VERIFIED FIXED
19 years ago
15 years ago

People

(Reporter: jim_nance, Assigned: cls)

Tracking

Trunk
mozilla0.9
DEC
OSF/1

Firefox Tracking Flags

(Not tracked)

Details

I am trying to build the 0.8.1 release under Tru64.  I am running into several
problems with NSPR:

1) In the directory nsprpub/pr/src the file prversion.c does
   not compile because the script that generates the macro
   _BUILD_TIME does not work right

2) in the directory nsprpub/pr/src we seem to be using the
   wrong command to build libnspr4.so:

/bin/ld  -o libnspr4.so ./prvrsion.o io/./prfdcach.o io/./prmwait.o
io/./prmapopt.o io/./priometh.o io/./pripv6.o io/./prlayer.o io/./prlog.o
io/./prmmap.o io/./prpolevt.o io/./prprf.o io/./prscanf.o io/./prstdio.o
threads/./prcmon.o threads/./prrwlock.o threads/./prtpd.o linking/./prlink.o
malloc/./prmem.o md/./prosdep.o memory/./prshm.o memory/./prshma.o
memory/./prseg.o misc/./pralarm.o misc/./pratom.o misc/./prcountr.o
misc/./prdtoa.o misc/./prenv.o misc/./prerr.o misc/./prerror.o
misc/./prerrortable.o misc/./prinit.o misc/./prinrval.o misc/./pripc.o
misc/./prlog2.o misc/./prlong.o misc/./prnetdb.o misc/./prolock.o misc/./prrng.o
misc/./prsystem.o misc/./prthinfo.o misc/./prtpool.o misc/./prtrace.o
misc/./prtime.o malloc/./prmalloc.o pthreads/./ptsynch.o pthreads/./ptio.o
pthreads/./ptthread.o pthreads/./ptmisc.o md/unix/./unix.o
md/unix/./unix_errors.o md/unix/./uxproces.o md/unix/./uxrng.o md/unix/./uxshm.o
md/unix/./uxwrap.o  -lpthread 
/bin/ld:
Can't locate file for: -lpthread

  Note that not only is -lpthread wrong, but this command will not generate a 
  shared lib in any case.

3) in pr/include/md/Makefile MDCPUCFG_H does not get defined and I cant
   not figure out why.  The OSF1 specific code looks OK.
Try a tip build.  0.8.1 doesn't have any of the nspr fixes that went in last week.
Priority: -- → P2
Target Milestone: --- → mozilla0.9
I just did a tip pull and tried to build.  At least problem #3 is still there:

../../../config/./nsinstall: cannot make symbolic link
/scratch/jlnance/build/dist/include/md: File exists

I tracked this down in the 0.8.1 build and its caused by MDCPUCFG_H not getting
defined.  Ill look more at this latter.  Im going to bed now.
What does ./nsprpub/build/autoconf/config.guess return ?  MDCPUCFG_H is set for
*-osf1*. 
bash-2.03$ ./mozilla/./nsprpub/build/autoconf/config.guess
alpha-dec-osf4.0f

That looks like it could be the problem.
Try this:

Index: nsprpub/configure.in
===================================================================
RCS file: /cvsroot/mozilla/nsprpub/configure.in,v
retrieving revision 1.18.2.42
diff -u -r1.18.2.42 configure.in
--- configure.in        2001/04/05 03:10:30     1.18.2.42
+++ configure.in        2001/04/06 20:08:40
@@ -1233,7 +1233,7 @@
     MKSHLIB='vmsld $(OPTIMIZER)'
     ;;
 
-*-osf1*)
+*-osf*)
     AC_DEFINE(XP_UNIX)
     AC_DEFINE(OSF1)
 
This patchlet fixes it.  I have a build now!
Patchlet checked in.  Marking fixed.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verified, based on jim's comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.