Last Comment Bug 749550 - dbg-server.jsm includes dbg-client.jsm with resource:/// instead of resource://gre/
: dbg-server.jsm includes dbg-client.jsm with resource:/// instead of resource:...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 740803
  Show dependency treegraph
 
Reported: 2012-04-27 02:24 PDT by Mike Hommey [:glandium]
Modified: 2012-05-04 02:19 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
unaffected
fixed


Attachments
Import dbg-client.jsm from resource://gre/ instead of resource:/// (1.14 KB, patch)
2012-04-27 02:29 PDT, Mike Hommey [:glandium]
past: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-04-27 02:24:43 PDT

    
Comment 1 Mike Hommey [:glandium] 2012-04-27 02:29:05 PDT
Created attachment 618957 [details] [diff] [review]
Import dbg-client.jsm from resource://gre/ instead of resource:///
Comment 4 Mike Hommey [:glandium] 2012-05-02 23:08:59 PDT
Comment on attachment 618957 [details] [diff] [review]
Import dbg-client.jsm from resource://gre/ instead of resource:///

[Approval Request Comment]
Regression caused by: bug 740803
User impact if declined: Debugger probably doesn't work on Firefox-on-xulrunner setups (used by some Linux distros)
Testing completed (on m-c, etc.): Landed on m-c a couple days ago.
Risk to taking this patch (and alternatives if risky): None. on Mozilla builds, resource://gre/ and resource:/// are strictly identical.
String changes made by this patch: None.
Comment 5 Alex Keybl [:akeybl] 2012-05-03 09:31:13 PDT
Comment on attachment 618957 [details] [diff] [review]
Import dbg-client.jsm from resource://gre/ instead of resource:///

(In reply to Mike Hommey [:glandium] from comment #4)
> User impact if declined: Debugger probably doesn't work on
> Risk to taking this patch (and alternatives if risky): None. on Mozilla
> builds, resource://gre/ and resource:/// are strictly identical.

Although we're not 100% sure of the user impact, it sounds like we're nearly 100% sure we won't cause a regression. Approving for Aurora 14.
Comment 6 Mike Hommey [:glandium] 2012-05-04 02:19:08 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/58fb08cbb6d3

Note You need to log in before you can comment on or make changes to this bug.