crash in nsCOMPtr_base::~nsCOMPtr_base | nsDocShell::LoadHistoryEntry

REOPENED
Unassigned

Status

()

--
critical
REOPENED
7 years ago
5 months ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, testcase})

Trunk
ARM
Android
crash, testcase
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

7 years ago
Steps to reproduce:
- Go to testcase
- Tap on the tab menu to open tab list popup
- Wait for at least 10 seconds, then close the tab with the testcase
- Tap on the "Resend" button in the dialog

Result: crash

Tested on the Samsung Galaxy SII and the Samsung Galaxy Nexus.

This bug was filed from the Socorro interface and is 
report bp-b5ce0a53-3118-4ef9-b083-6f4e52120427 .
============================================================= 
0 	libxul.so 	nsCOMPtr_base::~nsCOMPtr_base 	obj-firefox/xpcom/build/nsCOMPtr.cpp:81
1 	libxul.so 	nsDocShell::LoadHistoryEntry 	nsCOMPtr.h:480
2 	libxul.so 	nsDocShell::LoadURI 	docshell/base/nsDocShell.cpp:1419
3 	libxul.so 	nsFrameLoader::ReallyStartLoadingInternal 	content/base/src/nsFrameLoader.cpp:496
4 	libxul.so 	nsFrameLoader::ReallyStartLoading 	content/base/src/nsFrameLoader.cpp:432
5 	libxul.so 	nsDocument::MaybeInitializeFinalizeFrameLoaders 	content/base/src/nsDocument.cpp:5505
6 	libxul.so 	nsDocument::EndUpdate 	content/base/src/nsDocument.cpp:4048
7 	libxul.so 	nsHTMLDocument::EndUpdate 	content/html/document/src/nsHTMLDocument.cpp:2275
8 	libxul.so 	nsHtml5TreeOpExecutor::EndDocUpdate 	parser/html/nsHtml5TreeOpExecutor.h:294
9 	libxul.so 	nsHtml5TreeOpExecutor::RunFlushLoop 	parser/html/nsHtml5TreeOpExecutor.cpp:572
10 	libxul.so 	nsHtml5ExecutorFlusher::Run 	parser/html/nsHtml5StreamParser.cpp:160
11 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
(Reporter)

Updated

7 years ago
blocking-fennec1.0: --- → ?
Summary: crash in nsCOMPtr_base:: → crash in nsCOMPtr_base::~nsCOMPtr_base | nsDocShell::LoadHistoryEntry]

Updated

7 years ago
Hardware: All → ARM
Summary: crash in nsCOMPtr_base::~nsCOMPtr_base | nsDocShell::LoadHistoryEntry] → crash in nsCOMPtr_base::~nsCOMPtr_base | nsDocShell::LoadHistoryEntry
Whiteboard: [native-crash]
blocking-fennec1.0: ? → -
Component: General → Layout
Product: Fennec Native → Core
QA Contact: general → layout
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
Reopening because crash bugs **with testcases** should not be resolved **as WONTFIX** based on queries of crash-stats.  Other resolutions may be appropriate for other reasons.

(Crash signatures are not the same as bug identity; they're merely a search aid to find and group similar crashes.  The bug may still be present, but the signature may have changed slightly, or the bug may even still be present with the same signature but there are simply no recent reports of crashes in that function.)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
You need to log in before you can comment on or make changes to this bug.