crash in ~nsHttpConnectionInfo probly from SpeculativeConnect

RESOLVED DUPLICATE of bug 749182

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 749182
6 years ago
6 years ago

People

(Reporter: Robert Kaiser, Assigned: mcmanus)

Tracking

({crash})

Trunk
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-9417863b-3ae1-4bc0-8e28-64c812120427 .
============================================================= 

Top 10 Frames:

0 	nspr4.dll 	PR_DestroyMonitor 	nsprpub/pr/src/threads/prmon.c:86
1 	xul.dll 	nsTArray<nsMenuEntry*,nsTArrayDefaultAllocator>::RemoveElementsAt 	obj-firefox/dist/include/nsTArray.h:964
2 	xul.dll 	nsRefPtr<nsHttpConnectionInfo>::~nsRefPtr<nsHttpConnectionInfo> 	obj-firefox/dist/include/nsAutoPtr.h:908
3 	xul.dll 	nsPipe::Release 	xpcom/io/nsPipe3.cpp:339
4 	xul.dll 	nsCOMPtr_base::~nsCOMPtr_base 	obj-firefox/dist/include/nsAutoPtr.h:908
5 	xul.dll 	nsHttpPipeline::~nsHttpPipeline 	netwerk/protocol/http/nsHttpPipeline.cpp:121
6 	xul.dll 	nsHttpTransaction::WritePipeSegment 	netwerk/protocol/http/nsHttpTransaction.cpp:634
7 	xul.dll 	nsHttpPipeline::`vector deleting destructor' 	
8 	xul.dll 	nsPipeOutputStream::WriteSegments 	xpcom/io/nsPipe3.cpp:1137
9 	xul.dll 	nsHttpPipeline::Release 	netwerk/protocol/http/nsHttpPipeline.cpp:195
10 	xul.dll 	nsHttpTransaction::Close 	netwerk/protocol/http/nsHttpTransaction.cpp:790


More crashes at https://crash-stats.mozilla.com/report/list?signature=PR_DestroyMonitor%20%7C%20nsTArray%3CnsMenuEntry%2A%2C%20nsTArrayDefaultAllocator%3E%3A%3ARemoveElementsAt%28unsigned%20int%2C%20unsigned%20int%29%20%7C%20nsRefPtr%3CnsHttpConnectionInfo%3E%3A%3A~nsRefPtr%3CnsHttpConnectionInfo%3E%28%29%20%7C%20nsPipe%3A%3ARelease%28%29

This seems to only appear with the 20120426030504 64bit Windows Nightly build so far.
(Assignee)

Comment 1

6 years ago
seems to imply a double delete of a nsHttpConnectionInfo (or other ref counting issue), related to SpeculativeConnect I presume.
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED

Updated

6 years ago
Summary: crash in PR_DestroyMonitor → crash in nsHttpPipeline::~nsHttpPipeline
(Assignee)

Updated

6 years ago
Summary: crash in nsHttpPipeline::~nsHttpPipeline → crash in ~nsHttpConnectionInfo probly from SpeculativeConnect

Comment 2

6 years ago
It only happened in 15.0a1/20120426. It's fixed by bug 749182.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 749182
You need to log in before you can comment on or make changes to this bug.