Last Comment Bug 749700 - No "Reset Firefox" button in about:support with profiles created using ProfileManager
: No "Reset Firefox" button in about:support with profiles created using Profil...
Status: RESOLVED DUPLICATE of bug 1265368
:
Product: Testing
Classification: Components
Component: ProfileManager (show other bugs)
: 15 Branch
: All All
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 1157103 (view as bug list)
Depends on: 1265368
Blocks: reset-firefox 883627 717070
  Show dependency treegraph
 
Reported: 2012-04-27 10:50 PDT by [:Aleksej]
Modified: 2016-05-07 11:30 PDT (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description [:Aleksej] 2012-04-27 10:50:51 PDT
Firefox 13.0b1 and Nightly.

With profiles created using ProfileManager, about:support does not show the “Reset Firefox” button.  It is in the page’s code, but not displayed.
Comment 1 Jonathan Griffin (:jgriffin) 2012-04-27 10:58:40 PDT
I can confirm this.  The code that makes the 'reset' button visible is here:

http://mxr.mozilla.org/mozilla-central/source/toolkit/content/aboutSupport.js#623

My initial guess is that this happens because we're launching with a profile path and not a profile name.
Comment 2 Matthew N. [:MattN] 2012-07-06 23:34:35 PDT
Reset Firefox is only available if you are running the default (selected) profile.  The decision was made in Bug 717070 comment 6 to avoid having to pass the profile name and path between processes.
Comment 3 Rick Alther 2012-07-25 18:00:23 PDT
(In reply to Matthew N. [:MattN] from comment #2)
> Reset Firefox is only available if you are running the default (selected)
> profile.  The decision was made in Bug 717070 comment 6 to avoid having to
> pass the profile name and path between processes.

The platform should be changed to 'all' as I'm experiencing this on Win7 as well.

I read the referenced comment and can understand that this is considered a 'normal' user tool and the assumption is that anyone with multiple profiles are advanced users and don't need something like this.  However, it would still be a useful feature (certainly a time saver).  In addition, it would allow support folks who use multiple profiles to do testing and troubleshooting.
Comment 4 Florian Bender 2013-06-16 04:01:00 PDT
I cannot confirm this. Just reset a UX Nightly with a custom profile.
Comment 5 Matthew N. [:MattN] 2013-06-16 04:38:02 PDT
(In reply to Florian Bender from comment #4)
> I cannot confirm this. Just reset a UX Nightly with a custom profile.

See comment 2. It will work as long as it's the default/selected profile. Note that this bug is about the ProfileManager utility, not Firefox's built-in profile manager.
Comment 6 Florian Bender 2013-06-16 04:58:57 PDT
Sorry, didn't get that at first. I did use the internal profile manager, however it was not the default profile (though I selected it when starting Fx).
Comment 7 Manish Goregaokar [:manishearth] 2013-09-04 08:58:57 PDT
Jaws gave a good possible justification for this bug:

> <jaws> reason, because it makes it much more complicated to do the reset when there are multiple profiles. justification, users with  multiple profiles are expert enough to delete the profile, or something like that ;)

I think we can improve on this without overercomplicating things, though. When the reset button is not available on about:support, why not replace it with a button that summons the profile manager? Something like "If you're having major problems which you can't resolve, start fresh with a new profile". People who are on a different profile can then just use the profile manager (I'm assuming that they know how to, which seems reasonable)
Comment 8 Jared Wein [:jaws] (please needinfo? me) 2013-09-04 09:06:34 PDT
Preferred text would be, "If you're having major problems, I feel bad for you son. I got 99 problems but Firefox ain't one. [Reset me!]"

Reference: http://www.youtube.com/watch?v=WwoM5fLITfk
Comment 9 Grzegorz 2014-02-17 09:51:20 PST
I'm confirming this bug in Nightly 30.0a1 (2014-02-16) and 30.0a1 (2014-02-17). Reset button is visible when turn off styles (menu View > Page style > No style).
Comment 10 Kostas 2014-04-11 13:07:10 PDT
(In reply to Grzegorz from comment #9)
> I'm confirming this bug in Nightly 30.0a1 (2014-02-16) and 30.0a1
> (2014-02-17). Reset button is visible when turn off styles (menu View > Page
> style > No style).
The bug still occurs in Nightly 31.0a1 (2014-04-11)
Comment 11 Verdi [:verdi] 2015-04-22 09:54:37 PDT
*** Bug 1157103 has been marked as a duplicate of this bug. ***
Comment 12 Matthew N. [:MattN] 2016-05-05 15:03:59 PDT
I think bug 1265368 will fix this assuming the ProfileManager tool is updating profiles.ini
Comment 13 Matthew N. [:MattN] 2016-05-06 21:42:14 PDT
Can you see if this is fixed on tomorrow's Nightly please? If so, please dupe to bug 1265368. Thanks!
Comment 14 Sebastian H. [:aryx][:archaeopteryx] 2016-05-07 11:30:11 PDT
It's fixed in 49.0a1 2016-05-07. Thank you for taking care of this.

*** This bug has been marked as a duplicate of bug 1265368 ***

Note You need to log in before you can comment on or make changes to this bug.