If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[traceback] NoReverseMatch: Reverse for 'browse.language-tools.rss'

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: cvan, Assigned: davidbgk)

Tracking

Details

(Whiteboard: [contribute], URL)

(Reporter)

Description

6 years ago
http://sentry.dmz.phx1.mozilla.com/addons/group/53/

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "django/utils/decorators.py", line 91, in _wrapped_view
    response = view_func(request, *args, **kwargs)

  File "browse/views.py", line 364, in legacy_redirects
    url = reverse('browse.%s.rss' % type_slug, args=[cat.slug])

  File "amo/urlresolvers.py", line 60, in reverse
    url = django_reverse(viewname, urlconf, args, kwargs, prefix, current_app)

  File "django/core/urlresolvers.py", line 391, in reverse
    *args, **kwargs)))

  File "django/core/urlresolvers.py", line 337, in reverse
    "arguments '%s' not found." % (lookup_view_s, args, kwargs))
(Reporter)

Updated

5 years ago
Duplicate of this bug: 796031
(Reporter)

Updated

5 years ago
Duplicate of this bug: 850262
Whiteboard: [contribute]
(Assignee)

Comment 3

4 years ago
I can't reproduce that one, the redirection looks fine now (e.g. /en-US/firefox/browse/type:1/cat:1/format:rss). Can you try to reproduce and give me the URL you hit?
Assignee: nobody → david
Flags: needinfo?(cvan)
(Reporter)

Comment 4

3 years ago
(In reply to David Larlet [:davidbgk] from comment #3)
> I can't reproduce that one, the redirection looks fine now (e.g.
> /en-US/firefox/browse/type:1/cat:1/format:rss). Can you try to reproduce and
> give me the URL you hit?

Yes. https://addons.mozilla.org/de/firefox/browse/type:3/cat:95/format:rss?sort=updated
Flags: needinfo?(cvan)
(Assignee)

Comment 5

3 years ago
(In reply to Christopher Van Wiemeersch [:cvan] from comment #4)
> Yes.
> https://addons.mozilla.org/de/firefox/browse/type:3/cat:95/format:
> rss?sort=updated

To me that hit shouldn't occur given that type:3 is for language-tools which doesn't have, as far as I know, an RSS feed. It should only happen for type in (1, 2).

Is there any hit with that pattern against the prod on Sentry?
Flags: needinfo?(cvan)
(Reporter)

Comment 6

3 years ago
Do you need still need assistance with this?
Flags: needinfo?(cvan)
(Assignee)

Comment 7

3 years ago
I don't really need assistance for that one, I'm more wondering if I should close it as wontfix given that it should never happen for real. That's why I asked that question on comment 5.
(Assignee)

Comment 8

3 years ago
PR: https://github.com/mozilla/olympia/pull/319
(Assignee)

Comment 9

3 years ago
https://github.com/mozilla/olympia/commit/92a40d877148e86dfa82e6820e9a0ffeab0b4e0f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.