If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scratchpad fails to provide any feedback on objects that inherit from `null`

RESOLVED DUPLICATE of bug 807924

Status

()

Firefox
Developer Tools: Scratchpad
P3
normal
RESOLVED DUPLICATE of bug 807924
6 years ago
5 years ago

People

(Reporter: irakli, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

For example executing following will give no feedback:

Object.create(null)

That's because Object.create(null) + 'foo' will throw. Correct way of doing that would be:

((value && !('toString' in value)) ? Object.prototype.toString.call(value) : value) + 'foo'
this should go away when we move to using the debug protocol.

Filter on BLACKEAGLE?!
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807924
You need to log in before you can comment on or make changes to this bug.