nsUNIXCharset.cpp won't build - looking for gnu_get_libc_version, so HAVE_GNU_GET_LIBC_VERSION is wrongly configured.

VERIFIED DUPLICATE of bug 74758

Status

SeaMonkey
Build Config
--
blocker
VERIFIED DUPLICATE of bug 74758
17 years ago
13 years ago

People

(Reporter: Gyles Harvey, Assigned: cls)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.6 sun4u; en-US; 0.8.1) Gecko/20010321
BuildID:    20010405

The configure test:

#line 9858 "configure"
#include "confdefs.h"

        #ifdef HAVE_GNU_LIBC_VERSION_H
        #include <gnu/libc-version.h>
        #endif
        
int main() {
const char *glibc_version = gnu_get_libc_version();
; return 0; }

when run as configure does:

gcc -c <blah blah> conftest.c

Passes, as the syntax is OK. This is wrong. This can only be detected in the
linker (ie no -c flag).

Reproducible: Always
Steps to Reproduce:
1. configure...
2. make
3. fail.

Because test passes HAVE_GNU_GET_LIBC_VERSION gets set, leading to 
nsUNIXCharset.cpp failing to build.

Actual Results:  Build stopped.

Expected Results:  Build carried on to do more files...
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 74758 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.