If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bidi: Arabic Visual text is displayed reversed

RESOLVED FIXED

Status

()

Core
Layout: Text
--
major
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: Maha Abou El-Rous, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    00000000 - Bidi build dated 20010404

Arabic Visual text is displayed reversed

Reproducible: Always
Steps to Reproduce:
1.Open file CP864.htm


Actual Results:  Arabic text is displayed reversed

Expected Results:  Arabic text should be displayed without the extra reverse.
(Reporter)

Comment 1

17 years ago
Created attachment 29935 [details]
Arabic Visual LTR HTML file

Comment 2

17 years ago
we are focusing on landing IBMBIDI without breaking latin and CJK for moz0.9. 
Move this bidi functional bug to moz0.9.1 . maha- can you make two screen shot 
(use bigger text, please)- one with the expect result and one with the actual 
result. Thanks.
Target Milestone: --- → mozilla0.9.1

Comment 3

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang

Comment 4

17 years ago
mark it as assign
Status: NEW → ASSIGNED

Comment 5

17 years ago
decommit other bidi issue until we land IBMBIDI default on.

Updated

17 years ago
Target Milestone: mozilla0.9.1 → ---

Comment 6

17 years ago
reassign to simon@softel.co.il
Assignee: ftang → simon
Status: ASSIGNED → NEW

Comment 7

17 years ago
Changing QA contact to mahar@eg.ibm.com.
QA Contact: andreasb → mahar

Updated

17 years ago
Keywords: intl
(Reporter)

Comment 8

17 years ago
the code patch attached to bug# 81664 should fix this problem.

Updated

17 years ago
Depends on: 81664

Comment 9

17 years ago
Ftang - Pls Assign a target milestone. I suggest M0.9.2, if we are to supprt
this . . .
Keywords: nsbeta1

Comment 10

16 years ago
move to "Bidi:Hebrew/Arabic" componenet
Component: Internationalization → BiDi Hebrew & Arabic

Updated

16 years ago
Keywords: nsBranch

Comment 11

16 years ago
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: mahar → zach

Comment 12

16 years ago
Arabic contact to maha.
QA Contact: zach → mahar

Comment 13

16 years ago
Marking nsbranch- as it was decided in the August bug triage that we wouldn't
have enough time in eMojo to fix this.  Let's revisit for MachV.
Keywords: nsbranch-

Comment 14

16 years ago
removed keyword nsbranch since it now has nsbranch-, per pdt mtg.
Keywords: nsbranch
(Assignee)

Comment 15

16 years ago
Maha, please resolve this bug if it is fixed in current trunk builds.

Comment 16

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: mahar → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.