The default bug view has changed. See this FAQ.

Launcher panel moves to the top of about:home page when in RTL mode

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

13 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13+ verified, firefox14+ verified, firefox15 verified)

Details

(Whiteboard: [about-home][fixed by bug 750551][qa+])

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 619389 [details]
Screenshot of bug

I haven't figured out why yet, but the launcher area (with links to Downloads, Bookmarks, History, etc) that is located at the bottom of about:home in LTR mode, moves to the top of the page when in RTL mode.

Tested with 4/27 UX Nightly build and also seen on a local build of mozilla-central. RTL mode was achieved using the Force RTL mode add-on, which should simulate an RTL environment but there is a possibility that true RTL mode may function differently (I don't expect this to be the case though).

Screenshot of the bug attached.
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
OS: Windows 7 → All
Hardware: x86_64 → All
Version: Trunk → 13 Branch
This also makes the link to http://www.mozilla.org/about/ inaccessible. The link is in the top-right position for LTR, and should be in the top-left position for RTL.

Comment 2

5 years ago
(In reply to Jared Wein [:jaws] from comment #1)
> The
> link is in the top-right position for LTR, and should be in the top-left
> position for RTL.

No, the link is fine in the top right. Stephen and I discussed that. Not everything needs to be mirrored, and it's a non-localized wordmark anyway.
The launcher does need to be fixed though. I'll do that. Thanks for discovering and reporting this bug.
Assignee: nobody → fryn
Status: NEW → ASSIGNED
status-firefox13: affected → ---
status-firefox14: affected → ---
status-firefox15: affected → ---
tracking-firefox13: ? → ---
tracking-firefox14: ? → ---
OS: All → Windows 7
Hardware: All → x86_64
Version: 13 Branch → Trunk

Comment 3

5 years ago
Ugh, form restore bites me again.
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
OS: Windows 7 → All
Hardware: x86_64 → All
Version: Trunk → 13 Branch
Oh ok, the Mozilla link actually sits at the bottom right of the page when in RTL mode.
tracking-firefox13: ? → +
tracking-firefox14: ? → +
I've tracked it down to the display:-moz-box and -moz-box-orient:vertical properties on <body>.
This is a result of a layout bug, I'm in the process of filing it now.
Depends on: 750551

Updated

5 years ago
Whiteboard: [about-home]
Created attachment 620959 [details] [diff] [review]
Patch for bug

This patch would only be fore Fx13 beta and Fx14 aurora since the cause of the bug has been fixed in Fx15 nightly.
Attachment #620959 - Flags: review?(dao)
I'll add a comment to the CSS before landing to state that this is due to bug 750551.
Comment on attachment 620959 [details] [diff] [review]
Patch for bug

use the child selector

(There's no strong need to add a comment for bug 750551, as long as you don't land this on central.)
Attachment #620959 - Flags: review?(dao) → review-
Created attachment 621041 [details] [diff] [review]
Patch for bug v2

Gladly taking this :-)
Assignee: fryn → jwein
Attachment #620959 - Attachment is obsolete: true
Attachment #621041 - Flags: review?(dao)

Updated

5 years ago
Attachment #621041 - Flags: review?(dao) → review+
Comment on attachment 621041 [details] [diff] [review]
Patch for bug v2

[Approval Request Comment]
Regression caused by (bug #): bug 750551 

User impact if declined:
The new about:home design has its elements out of order in RTL mode.

Testing completed (on m-c, etc.):
Locally, but specifically not landed on mozilla-central because bug 750551 will be fixed in Fx15-Nightly. Bug 750551 will intentionally not land in Fx13-Beta or Fx14-Aurora since it has the potential to break layouts of websites.

Risk to taking this patch (and alternatives if risky): none expected
String changes made by this patch: none
Attachment #621041 - Flags: approval-mozilla-beta?
Attachment #621041 - Flags: approval-mozilla-aurora?
Comment on attachment 621041 [details] [diff] [review]
Patch for bug v2

[Triage Comment]
If the CSS changes could cause regressions outside of RTL, I would have suggested we land on Aurora 14 a few days before Beta 13. Since that isn't the case, approving for both versions.
Attachment #621041 - Flags: approval-mozilla-beta?
Attachment #621041 - Flags: approval-mozilla-beta+
Attachment #621041 - Flags: approval-mozilla-aurora?
Attachment #621041 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/dd43cd34d18c
https://hg.mozilla.org/releases/mozilla-beta/rev/c06a6cae7649
status-firefox13: affected → fixed
status-firefox14: affected → fixed

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Frank tested bug 750551 on mozilla-central to make sure that this bug has been fixed on trunk.
status-firefox15: affected → fixed
Whiteboard: [about-home] → [about-home][fixed by bug 750551]
Whiteboard: [about-home][fixed by bug 750551] → [about-home][fixed by bug 750551][qa+]
Verified on Firefox 13 beta 3 that when in RTL mode the Launcher panel of the about:home page is located at the bottom. 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7 using the instructions from the description on an en-US build (installed and enabled the Force RTL add-on) and on an RTL build (ar).

Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0
status-firefox13: fixed → verified
Verified on Firefox 14 beta 7 that when in RTL mode the Launcher panel of the about:home page is located at the bottom. 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.6 using the instructions from the description on an en-US build (installed and enabled the Force RTL add-on) and on an RTL build (ar).

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
معرّف البناء: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0

Build identifier: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0
معرّف البناء: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0
معرّف البناء: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0
status-firefox14: fixed → verified
Verified on Firefox 15 beta 2 that when in RTL mode (that was achieved on an en-Us build with the add-on Force RTL or on an ar build) that the Launcher panel of the about:home page is located at the bottom.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.6.

Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
معرّف البناء: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Build identifier: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0	
معرّف البناء: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
معرّف البناء: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.