Selecting text at a ligature boundary causes the ligatures to be broken

RESOLVED FIXED in Future

Status

()

defect
P4
trivial
RESOLVED FIXED
18 years ago
8 years ago

People

(Reporter: mrous, Assigned: smontagu)

Tracking

({intl})

Trunk
Future
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    00000000 - Bidi build dated 20010404

Arabic text during selection with mouse shifts a bit.

Reproducible: Always
Steps to Reproduce:
1.Open file testutf8.htm
2.Select encoding to be Unicode UTF-8
3. try to select part of a sentence


Actual Results:  Arabic text being selected shifts a bit.

Expected Results:  try same scenario on IE5 for correct results
Reporter

Comment 1

18 years ago
Posted file Arabic Unicode file

Comment 2

18 years ago
we are focusing on landing IBMBIDI withoug breaking Latin/CJK. move this bidi 
functional bug to moz1.0
Target Milestone: --- → mozilla1.0

Comment 3

18 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang

Comment 4

18 years ago
mark it as assign
Status: NEW → ASSIGNED

Comment 5

18 years ago
remove moz1.0
Target Milestone: mozilla1.0 → ---

Comment 6

18 years ago
reassign to simon@softel.co.il
Assignee: ftang → simon
Status: ASSIGNED → NEW

Comment 7

18 years ago
Changing QA contact to mahar@eg.ibm.com.
QA Contact: andreasb → mahar

Updated

18 years ago
Keywords: intl

Updated

18 years ago
Component: Internationalization → BiDi Hebrew & Arabic

Updated

18 years ago
Keywords: nsbeta1
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: mahar → zach

Comment 9

18 years ago
QA back to mahar.
QA Contact: zach → mahar

Updated

18 years ago
Blocks: 104166

Updated

18 years ago
Blocks: 115713

Comment 10

18 years ago
This bug does not only affect Arabic but probably all complex scripts.  That is,
those where rendering involves ligature substitution.  I've seen the same problem
on Mac with Arabic and with Devanagari/Hindi.  It seems selecting text at a
ligature boundary causes the ligatures to be broken and the non-ligated
characters in the glyph to be rendered separately on the left and rights sides
of the selection boundary.

Instead, the selection colour block may need to be
rendered over the top of the rendered text.

Hindi test page is at:
http://www.unicode.org/unicode/standard/translations/hindi.html
Assignee

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 11

17 years ago
While making a testcase for another bug, I noticed that the arabic text doesn’t
move if align justify is set.

Try selecting some text at:
http://bugzilla.mozilla.org/attachment.cgi?id=109394&action=view
Assignee

Updated

17 years ago
Depends on: 192919

Comment 12

16 years ago
Kindly be informed that Ahmad A. Abu-Taha (ahtaha@eg.ibm.com) from IBM Egypt is 
replacing Maha Abou El-Rous (mahar@eg.ibm.com | mrous@hotmail.com) in 
monitoring and receiving notifications of Mozilla bugs regarding Arabic.
Priority: -- → P4
Target Milestone: --- → Future
Assignee

Comment 13

16 years ago
*** Bug 215796 has been marked as a duplicate of this bug. ***
Assignee

Comment 14

16 years ago
Changing summary and moving component.
Component: BiDi Hebrew & Arabic → Layout: Fonts and Text
Summary: Bidi: during selection with mouse, text moves a bit → Selecting text at a ligature boundary causes the ligatures to be broken

Comment 15

16 years ago
Adding some CTL people to CC because it's not only about BIDI but also about
complex scripts in general. 
OS: Windows 98 → All
Hardware: PC → All

Comment 16

16 years ago
I don't want to split hairs, but the summary could be more informative. 

The bug appears to relate to combining character boundaries and arabic joining
properties as well as ligature boundaries.

How about: Text selections ending inside graphemes or between joining arabic
characters cause characters to be displayed independently
Assignee

Comment 17

16 years ago
*** Bug 224066 has been marked as a duplicate of this bug. ***
Assignee

Comment 18

15 years ago
*** Bug 237932 has been marked as a duplicate of this bug. ***
Assignee

Updated

15 years ago
Depends on: grapheme-breaker

Comment 19

15 years ago
I can't reproduce Bug 75011 (Moz1.5 on WinXPSP1)
screenshot: http://www.byteshift.de/msg/div/bugzilla/75011.png

Comment 20

15 years ago
I can no longer reproduce the bug on mozila 1.6 in linux
I can't reproduce it with the attached test case, but
http://www.unicode.org/unicode/standard/translations/hindi.html _seems_ to show
the bug still, on a Windows Firefox 0.9 installation.

Comment 22

15 years ago
I definitely CAN reproduce this (with the testcase) with Firefox 0.9 and the
latest suite on WinXP.

Comment 23

15 years ago
Thanks to the input from Mike and his Hindi findings, there is some good news 
and some bad news. The bad news is that this bug likely occurs in all complex 
scripts i.e., Arabic, Indic, Thai, etc. I found it also in:
http://www.unicode.org/standard/translations/thai.html
If there were some rendered complex text Khmer, Lao or other HTML examples (I'm 
looking), we would see this bug reproduce there as well. I'm sure that Mozilla 
tracks both visual and logical representations for the purpose of text 
selection, but it is trying to display logical information rather than visual. 
Could someone let me know is Mozilla using the ICU renderer for this? I'm 
guessing not given the bad behaviors we see, but that code might help us find a 
solution for this bug.

Also, in general, BiDi shaping and layout go hand-in-hand as major facets for 
BiDi support. That this bug now assumes a much broader scope/impact, it should 
have both a higher severity and priority. I'm not sure I can change those 
values, but someone should.

Comment 24

15 years ago
Note that this bug depends on bug 229896. 
Assignee

Comment 25

15 years ago
*** Bug 252716 has been marked as a duplicate of this bug. ***

Comment 26

15 years ago
Is this fixed in Firefox 1.0? I'm definitely not reproducing it in the test
attachment or on other pages (like
http://annevankesteren.nl/archives/2004/05/unicode).

Comment 27

15 years ago
No. It is still a bug -- even in Firefox 1.0. I can reproduce it with a number
of languages and test cases -- including the Hindi in the test URL with the last
comment. Not sure why you are not able to reproduce it. Feel free to write me
individually and we can compare bug reproduction steps. The text should
literally jump out at you when you change the selection area size -- with the
characters themselves changing shape or representative glyphs.

Comment 28

15 years ago
Never mind, I see it at home but not at school, both WinXP, Firefox 1.0. I bet
it has something to do with the fonts installed. I'll look into it when I can
get back to the school computers.
Assignee

Comment 29

15 years ago
Maybe one of the computers has support for complex text installed and the other
does not? See Control Panel | Regional and Language Options -- is the checkbox
"Install files for complex script and right-to-left-languages" checked?

Comment 30

15 years ago
I have complex text settings properly configured. Running a test with FireFox
1.0 browser reveales interesting results. I put the URLs here for you and hope
they're clickable. The language of test pages is Persian.

http://www.unicode.org/standard/translations/persian.html (The bug is reproducible)

http://shabah.org  (the bug is NOT reproducible)
Assignee

Comment 31

15 years ago
(In reply to comment #30)
> http://shabah.org  (the bug is NOT reproducible)

That's because it has "text-align: justify", as noted in comment 11.

Assignee

Comment 32

15 years ago
*** Bug 278183 has been marked as a duplicate of this bug. ***
Assignee

Comment 33

15 years ago
*** Bug 280810 has been marked as a duplicate of this bug. ***

Comment 34

14 years ago
I cannot reproduce it on Firefox 1.5 on Ehad (Mandriva 2006) Linux, downloaded from Mozilla's FTP. Worksframe?

User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Comment 35

14 years ago
Can't reproduce this one either in any of the testcases... calling worksforme.
if anyone else calls worksforme please mark the bug resolved.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Assignee

Comment 36

14 years ago
This bug only appears on certain combinations of OS, build options and system options. The fact that not everybody can reproduce it does not make it WORKSFORME.

Comment 37

14 years ago
(In reply to comment #36)
> This bug only appears on certain combinations of OS, build options and system
> options. The fact that not everybody can reproduce it does not make it
> WORKSFORME.
> 

But I could reproduce it in version 1.0.7. Can someone reproduce it in 1.5?

Comment 38

14 years ago
(In reply to comment #37)
> (In reply to comment #36)
> > This bug only appears on certain combinations of OS, build options and system
> > options. The fact that not everybody can reproduce it does not make it
> > WORKSFORME.
> > 
> 
> But I could reproduce it in version 1.0.7. Can someone reproduce it in 1.5?

I bet your 1.0.7 was built with pango *disabled* while your copy of 1.5 was built with pango *enabled*. Type 'about:buildconfig' in the url bar and see which of two has  '--enable-pango' and which doesn't.  


Comment 39

14 years ago
(In reply to comment #38)
> I bet your 1.0.7 was built with pango *disabled* while your copy of 1.5 was
> built with pango *enabled*. Type 'about:buildconfig' in the url bar and see
> which of two has  '--enable-pango' and which doesn't.  

I've already uninstalled Firefox 1.0.7, but in Firefox 1.5 I don't see any reference to "pango" at all. This is the whole page in Firefox 1.5:

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --disable-debug '--enable-optimize=-Os -freorder-blocks -fno-reorder-functions -gstabs+' --disable-tests --enable-official-branding --enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --enable-svg --enable-canvas --enable-static --disable-shared 

Comment 40

13 years ago
Firefox 2 beta 1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1) doesn't seem to be affected by this bug.  Is it fixed?

Comment 41

12 years ago
I also can't reproduce using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007080204 Minefield/3.0a7pre. Build parameters:

--enable-application=browser --enable-update-channel=nightly --enable-optimize --disable-debug --disable-tests --enable-update-packaging

Comment 42

12 years ago
(In reply to comment #41)
> I also can't reproduce using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US;
> rv:1.9a7pre) Gecko/2007080204 Minefield/3.0a7pre. Build parameters:
> 
> --enable-application=browser --enable-update-channel=nightly --enable-optimize
> --disable-debug --disable-tests --enable-update-packaging
> 

Same here on the following build as well:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081602 Minefield/3.0a8pre

about:buildconfig

Build platform
target
i686-pc-cygwin

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE) -I/usr/X11R6/include

Configure arguments
--enable-application=browser --enable-application=browser --disable-debug --enable-optimize --enable-canvas --enable-svg --enable-xpctools --enable-places --enable-places-bookmarks --enable-storage --enable-safe-browsing --enable-url-classifier --enable-strip --disable-javaxpcom 
Assignee

Comment 43

12 years ago
This is fixed on all platforms by the new text frame code. If there are any remaining issues, please file new bugs.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Depends on: 367177
Resolution: --- → FIXED

Updated

12 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.